Small leak under engine - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Engine Specific Tech For all Ford Engines from Bigblocks to Clevelands.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-23-2010, 04:09   #1 (permalink)
Registered User
 
Join Date: Jul 2010
Posts: 1
Small leak under engine

You'll have to excuse me I know nothing about cars and have only been driving for a few months. I drive a '52' plate red KA

Two days ago, my engine temperature light came on for around 5minutes, but by the time I stopped it had already gone off. The next morning, I noticed that my small tank where water goes in was more or less empty and that there was a puddle of water under my car. I topped it up, but I did NOT drive my car until the next day.

Although the next day there was a puddle of water under the car, the tank was only just below the min. line.

My boyfriend took it to a garage and he said that they THINK the 'Thermisor(?) had become cracked and worn away and that it is a common problem in KAs'

Those were his exact word, I was told that it would cost around £90 to be looked at and for the part and the part to be fitted.

Could someone tell me what they think of the situation and if that it is this that seems to be the problem.
I would be extremely thankful.
RedKA is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-23-2010, 14:49   #2 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 7
Re: Small leak under engine

hello,
i don't know the specifics of your particular vehicle, but if you topped up the tank and did not drive, then it seems very unlikely that it is your thermostat. this is the part that regulates the flow of coolant around your engine, and if the engine did not run, but you still lost coolant, i can't see how it could be the thermostat.
if it is leaking without the engine running, it is more likely a split pipe somewhere.
hope this helps, matt
matt2704 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 21:47.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.