ef ford - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Australian Ford's Discussion For Discussing Aussie built Ford's. Falcon, FPV, Territory

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-29-10, 08:55 AM Thread Starter
Registered User
 
Join Date: May 2010
Posts: 1
ef ford

has any one had any problems when they changed an engine in thier ef ford. mine now has a street fighter engine from jim mock which cost a dam lot and wont rev up properly until 1900rpm from there it seems to rev up fine both in drive and not in drive. timing and cam angle has been checked and rechecked, throttle position checked, fuel pump replaced, injectors, everything ignition wise changed. cpu interchanged to another working cpu. i have been advised that it might be running lean ie not getting enough fuel. would this have something to do woth the fuel regulator??? this problem all started from after i installed the engine and not before with the old engine.

1995 EF Ford GLI - Jim Mock Street Fighter Motor - Pacemaker Headers - Sports 2 1/2 inch Exhaust Kit - Pod Filter

mefart2010 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome