88 5.0 HO back firing though intake - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Regional Clubs and Events > Arizona Mustang Car Club
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-02-2009, 15:29   #1 (permalink)
Registered User
 
Join Date: Sep 2009
Posts: 1
88 5.0 HO back firing though intake

I have an 88 5.0 HO and the car was in storage for two years and I think the fuel turned, so I drained and removed the fuel tank, cleaned what I could and changed the fuel filter twice. The car still back fires through the intake but not the exhaust, the firing order is right the timing marks align with the crankshaft pulley the rotor is positioned properly in the distributor. I do not have any electronic test capabilities and I am somewhat retarded on computer controlled vehicles. This car only has 140K on the clock and has spent a lot time in storage due to the fact that I work outside of the country. Can anyone help me? Thank you in advance. Van
valhalla1948 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-04-2009, 00:10   #2 (permalink)
Registered User
 
Join Date: Sep 2009
Location: Napier NZ
Posts: 1
Re: 88 5.0 HO back firing though intake

Mate same problem here except i got EF xr8 n changed intake over to a cobra one and have set everything and am still getting backfire throught intake, can someone help? is it computer?
EVLXR8 is offline   Reply With Quote
Old 11-16-2009, 20:55   #3 (permalink)
Chuck
 
Join Date: Nov 2009
Location: Sunny Phoenix, AZ
Posts: 2
Re: 88 5.0 HO back firing though intake

If it has been sitting for that long, I'd also check the fuel injectors (send them to WitchHunters in Oregon) to have them cleaned and flow tested. Is the timing correct? Usually backfiring through the intake is a timing issue (you obviously have fuel and spark, else no fire at all!). Check to be sure that your timing is not 180 degrees out of phase. That's where I'd start.
cyoung311 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Regional Clubs and Events > Arizona Mustang Car Club



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 08:34.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.