Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars - View Single Post - nightmare of a problem, need help
View Single Post
post #6 of (permalink) Old 03-05-15, 11:15 PM
amc49
Registered User
 
Join Date: Feb 2015
Posts: 182
Re: nightmare of a problem, need help

That makes sense, a possible toasted relay issue. Don't know myself on that earlier model but often a main 'EEC power relay' is used to power up lots of those things you are complaining about, could be an issue with that too.

You're missing something, no magic there, you're getting power when not wanted or grounded shorts to activate those devices, the wiring (at least some of it) CANNOT be good with that present.

You can always start yanking fuses to power down the shorted devices and see what leg of harness that sends you to. The shorted fuse may kill devices without even being the fuse for them, that would point toward where it could be.

I'd be looking close at any diodes in there anywhere as well, although they didn't use as many back then as now.

Biggest issue will be sitting down and carefully thinking about every step you take, it is very easy to get lost in that stuff not doing that. One person doing it rather than two or more is better, too easy to get out of communication there, but it means the one person must be sharp at it.

One of the first things I'd be sorting out is whether the errant devices are grounding when they shouldn't be or powered up with a permanent ground and powering up is the problem there. The schematic may easily sort that out.

Another horror story possibility.............there can be short(s) in there in such a way so that every GOOD PCM that plugs in is instantly blown out. Not a happy thought but pretty unlikely.
amc49 is offline  
 
 
For the best viewing experience please update your browser to Google Chrome