Clockspring? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 05-06-19, 11:16 PM Thread Starter
Registered User
 
Join Date: May 2019
Posts: 10
Clockspring?

Greetings!

I could use some help from anyone who may have experienced the problem I am having with my new-to-me '97 Merc Grand Marquis.

I've only had the car for about a month. Horn and cruise worked for about a week and both stopped working at the same time. My first thought was the clockspring - but I'm not getting the Air Bag light that commonly appears when the CS goes bad. Can the clockspring cause the horn and cruise to stop working but not show a problem with the air bag?

I've looked at the fuses and they appear okay. I don't mind swapping the CS if that's the culprit but since I haven't had a failure of all three devices in the steering wheel I wanted to ask for another opinion.

Thanks for any help or advice.

BTW, this is my first car in 30 years. I've always driven trucks, but I have to admit that I am really enjoying this old car. 22MPG, floats like a cloud, 114K miles, runs perfect - except for a 3-4 second stumble at cold start up, clean and appears well maintained. No wonder this platform was so popular. These are great cars!

jrfintex is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-07-19, 01:45 PM
Moderators
 
Join Date: Apr 2016
Location: Naples, Fl
Posts: 752
Re: Clockspring?

Does the airbag light work when the key is cycled?


Sent from my iPhone using Tapatalk

07 Gt Tungsten Grey
Roush (Airaid) Cai, GT500 Tb with BlowByRacing Adaptor Plate, UPR O/r X Pipe, M80's, Pypes Muffler Delete Axle Back, Sr Performance Adjustable Motor Mounts and Steeda Tri Ax Short Throw Shifter

02 Gt Mineral Grey
Steeda Sport Springs, 3.73s, Pro5.0 Short Shifter, Pypes O/r X Pipe, full 2.5 inch exhaust with M80's, 75mm Tb and C&L Plenum

87 Mercury Grand Marquis
85ltdcrownvic is offline  
post #3 of 9 (permalink) Old 05-07-19, 06:17 PM Thread Starter
Registered User
 
Join Date: May 2019
Posts: 10
Re: Clockspring?

Quote:
Originally Posted by 85ltdcrownvic View Post
Does the airbag light work when the key is cycled?


Sent from my iPhone using Tapatalk
Yes it works fine when cycled which is why I'm hesitant right now to buy a clockspring. What else would knockout the horn and cruise but not the CS?.
jrfintex is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 05-07-19, 08:39 PM
Moderators
 
Join Date: Apr 2016
Location: Naples, Fl
Posts: 752
Re: Clockspring?

How do you know its not throwing airbag codes, are you using a code reader or watching for the airbag light to flash?

Another thing you could try is adjusting the wheel up and down in various positions to see if that has any effect. It could be pinched/frayed wires.


Sent from my iPhone using Tapatalk

07 Gt Tungsten Grey
Roush (Airaid) Cai, GT500 Tb with BlowByRacing Adaptor Plate, UPR O/r X Pipe, M80's, Pypes Muffler Delete Axle Back, Sr Performance Adjustable Motor Mounts and Steeda Tri Ax Short Throw Shifter

02 Gt Mineral Grey
Steeda Sport Springs, 3.73s, Pro5.0 Short Shifter, Pypes O/r X Pipe, full 2.5 inch exhaust with M80's, 75mm Tb and C&L Plenum

87 Mercury Grand Marquis
85ltdcrownvic is offline  
post #5 of 9 (permalink) Old 05-07-19, 10:32 PM Thread Starter
Registered User
 
Join Date: May 2019
Posts: 10
Re: Clockspring?

Quote:
Originally Posted by 85ltdcrownvic View Post
How do you know its not throwing airbag codes, are you using a code reader or watching for the airbag light to flash?

Another thing you could try is adjusting the wheel up and down in various positions to see if that has any effect. It could be pinched/frayed wires.


Sent from my iPhone using Tapatalk
This is a learning process for me and I'm not sure it didn't throw a code. I only know the AB light come on when I start the car and then goes off after maybe 5 seconds. I figured if a wire was broke the bag light would turn the light on until fixed.

I can see in Autozone can find one if you think that will help. The car seems perfect except for the cold start shudder and shake. That also clears up after 5 seconds or so.
jrfintex is offline  
post #6 of 9 (permalink) Old 05-08-19, 08:17 AM
Moderators
 
Join Date: Apr 2016
Location: Naples, Fl
Posts: 752
Re: Clockspring?

The reason I ask about the code reader is that airbag codes cant be read by a code reader. They flash codes after the car starts. For example, code 22 would display as; start the car, airbag light stays on for 5 seconds, turns off, then flashes twice, short pause then flashes twice more, then a longer pause and more codes are displayed or the same code repeats if there are no more airbag codes. Its like reading obd1 codes.

Have you tried adjusting the wheel to see if that had any effect?


Sent from my iPhone using Tapatalk

07 Gt Tungsten Grey
Roush (Airaid) Cai, GT500 Tb with BlowByRacing Adaptor Plate, UPR O/r X Pipe, M80's, Pypes Muffler Delete Axle Back, Sr Performance Adjustable Motor Mounts and Steeda Tri Ax Short Throw Shifter

02 Gt Mineral Grey
Steeda Sport Springs, 3.73s, Pro5.0 Short Shifter, Pypes O/r X Pipe, full 2.5 inch exhaust with M80's, 75mm Tb and C&L Plenum

87 Mercury Grand Marquis
85ltdcrownvic is offline  
post #7 of 9 (permalink) Old 05-08-19, 10:55 PM Thread Starter
Registered User
 
Join Date: May 2019
Posts: 10
Re: Clockspring?

Quote:
Originally Posted by 85ltdcrownvic View Post
The reason I ask about the code reader is that airbag codes cant be read by a code reader. They flash codes after the car starts. For example, code 22 would display as; start the car, airbag light stays on for 5 seconds, turns off, then flashes twice, short pause then flashes twice more, then a longer pause and more codes are displayed or the same code repeats if there are no more airbag codes. Its like reading obd1 codes.

Have you tried adjusting the wheel to see if that had any effect?


Sent from my iPhone using Tapatalk
Tried it tonight. Up, down, turned the wheel while pushing the horn and cruise but no joy. Didn't even get a peep. I'll pull the fuses again and check with a continuity tester.

I appreciate the helpful tips!
jrfintex is offline  
post #8 of 9 (permalink) Old 05-10-19, 08:15 PM Thread Starter
Registered User
 
Join Date: May 2019
Posts: 10
Re: Clockspring?

Okay. The horn is shorted.

I bought the car used about 6 weeks ago and did not get a manual with it so I Googled the fuse diagram. Found one that listed the location of one fuse under the dash that fed the cruise control but it tested okay. Searched further and found a diagram of the fuse block under the hood but no mention of a cruise fuse. Started checking the anyway and the horn fuse was blown. That explained the horn problem but what about the cruise?

Replaced the 15A fuse and hit the horn and it grunted once and blew the new fuse again. Disconnected the horn, replaced the fuse (10A was all I had left), hit the horn again and heard the relay click but the fuse did not blow. This told me the electrical was okay so the horn must be bad. I went for a drive and now the cruise is working again.

I found nothing in the diagram indicating that the horn fuse under the hood would also feed the CC but apparently it does, so to summarize, my cruise stopped working because my horn shorted and blew the fuse which is why I lost both at the same time.
jrfintex is offline  
post #9 of 9 (permalink) Old 05-11-19, 06:33 AM
Moderators
 
Join Date: Jul 2011
Posts: 1,044
Re: Clockspring?

I think some of the circuits from the steering wheel run through the multi switch.
Bajarider is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Airbag Failure Bob1958 Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 10 10-28-09 04:45 AM
05 Bronze Bull Clockspring... fuumanstu Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 0 03-12-09 10:01 AM
Clockspring! ivaan Ford Ranger Forum 1 02-06-09 03:51 PM
after r&r engine cruise & horn? doesn't work jaycuzz Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 9 06-29-07 05:30 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome