Where the FRICK is the SRS module?!?! - Page 2 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Probe Forum | Mazda MX6 Forum Forum for discussion of the Ford Probe and Mazda MX6.

Closed Thread
 
LinkBack Thread Tools Display Modes
post #11 of 18 (permalink) Old 11-29-01, 08:49 PM
Big Poppa
 
fiveliter302's Avatar
 
Join Date: Sep 2001
Location: Akron, OH
Posts: 441
Im still not sure.... Ill check and see when I drive the car at night again...


"Filthy Degenerate"
1997 Ford Probe 2.0, 1993 Ford Probe GT 2.5L(Project), 1991 Ford Explorer XLT 4wd
1992 Probe GL (RIP),
83, 89, 93 Mustangs- (Bye Bye), 1988 Ranger XLT- (Also gone)
NOPOC
fiveliter302 is offline  
Sponsored Links
Advertisement
 
post #12 of 18 (permalink) Old 12-01-01, 03:56 PM
Big Poppa
 
fiveliter302's Avatar
 
Join Date: Sep 2001
Location: Akron, OH
Posts: 441
Oh, by the way... I drove the Probe and my airbag light did come on for a few secs when I started the car... Ill look in my service manual sometime here and see what it might be on yours... (You might have to remind me because I have a bad memory about things)

"Filthy Degenerate"
1997 Ford Probe 2.0, 1993 Ford Probe GT 2.5L(Project), 1991 Ford Explorer XLT 4wd
1992 Probe GL (RIP),
83, 89, 93 Mustangs- (Bye Bye), 1988 Ranger XLT- (Also gone)
NOPOC
fiveliter302 is offline  
post #13 of 18 (permalink) Old 12-01-01, 11:10 PM Thread Starter
97 Probe SE
 
Join Date: Aug 2001
Location: Lima, OH
Age: 37
Posts: 66
OK, I'll remind you......

Please look in your sevice manual to find out what it means when the Airbag light doesn't come on......LoL
stavesacre21 is offline  
Sponsored Links
Advertisement
 
post #14 of 18 (permalink) Old 12-10-01, 07:47 PM
Probe SE driver
 
Join Date: Dec 2001
Location: Mobile AL
Posts: 99
dunno if you found the module or not man. but if you didn't, it would be located right above your left foot under the drivers dash. It is hanger down kinda in front of the clutch(if you have) pedel and is a Blue Box about 6"x4"x2" in size.

~PSE driver
ALPOC Moderator, Co-founder, & Active Member
PSE driver is offline  
post #15 of 18 (permalink) Old 12-10-01, 08:21 PM
Big Poppa
 
fiveliter302's Avatar
 
Join Date: Sep 2001
Location: Akron, OH
Posts: 441
Im glad someone remembered!

"Filthy Degenerate"
1997 Ford Probe 2.0, 1993 Ford Probe GT 2.5L(Project), 1991 Ford Explorer XLT 4wd
1992 Probe GL (RIP),
83, 89, 93 Mustangs- (Bye Bye), 1988 Ranger XLT- (Also gone)
NOPOC
fiveliter302 is offline  
post #16 of 18 (permalink) Old 12-14-01, 11:03 PM
Big Poppa
 
fiveliter302's Avatar
 
Join Date: Sep 2001
Location: Akron, OH
Posts: 441
Hey, check this out... maybe this will help... it tells how to test the SRS computer and read the code for it.... Someone else posted it in another area for reading the ECU codes, but if you hook up the connector to read the SRS computer code it should flash a code if you have a problem....
http://home.golden.net/~trinity/main...t.htm#malfcode
This link starts in the middle of the page... You might want to go to the top.... This is for the 2.5 engine, I dont know if itll be the same or not... there might be something on here though for the 2.0....

"Filthy Degenerate"
1997 Ford Probe 2.0, 1993 Ford Probe GT 2.5L(Project), 1991 Ford Explorer XLT 4wd
1992 Probe GL (RIP),
83, 89, 93 Mustangs- (Bye Bye), 1988 Ranger XLT- (Also gone)
NOPOC
fiveliter302 is offline  
post #17 of 18 (permalink) Old 03-21-06, 01:52 PM
Eduardo
Guest
 
Posts: n/a
biggrin Re: Where the FRICK is the SRS module?!?!

Quote:
Originally Posted by jared r
either in the dash or behind the console.. i think its in the dash.. what model do u have.. are u thinking of disconnecting it.. be careful if you are.. those things are like dynamite if they go off. :crazy1:

do u know how to take out the SRS module? If u do colud u tell me how to do it. emale me at [email protected]
thank you
 
post #18 of 18 (permalink) Old 07-19-19, 04:08 PM
Registered User
 
Join Date: Jul 2019
Posts: 2
Re: Where the FRICK is the SRS module?!?!

My 1998 F150 has airbag light on the dash. Truck was old and half lamps out on the cluster. Removed cluster and replaced all lamps on it. Found out it has no cruise light or high beam light. Those were added in 99 or 2000.
chipmanii is offline  
Sponsored Links
Advertisement
 
Closed Thread

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Probe Forum | Mazda MX6 Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ignition module sideshowfreak Interior | Electrical | ECU 4 06-02-03 12:57 AM
Ignition module and coil durability? brenx General Tech 2 03-22-03 10:09 PM
TFI Module... AGAIN!!! XplodEd EA General Tech 6 06-21-02 04:00 AM
EEC module for a 1984 E150 szepj1 Ford Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar 0 12-15-01 12:36 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome