Brake failed and battery light on while start - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-16-08, 09:07 AM Thread Starter
Registered User
 
Join Date: Sep 2008
Posts: 2
Brake failed and battery light on while start

I have a 1999 Taurus. The "service engine soon" light was flashing, and a mechanic said one of the 6 cylinders failed. There was no other problem (as he said) and the cost to fix is too high so he suggest we continue driving the car without fixing the problem (until other problems fail the car). It worked well, for 4 months. Yesterday when I started the car, and shift to "R", I noticed the brake failed (so it kept moving), and battery light was on. I had to shift to "P" to stop it. Then I restarted the car, and all problems went away (brake worked again, and battery light was off). After that it worked well the whole day. Can somebody please let me know what the problem would be? Any suggestions? Thank you in advance.

tobyvivi is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-16-08, 09:47 AM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,739
Re: Brake failed and battery light on while start

Since you stated that you restarted the car, I'm assuming it knocked off. If so, then the battery light would be on and the power brakes would not work correctly.
thefonz is offline  
post #3 of 3 (permalink) Old 09-16-08, 10:27 AM Thread Starter
Registered User
 
Join Date: Sep 2008
Posts: 2
Re: Brake failed and battery light on while start

Yes I knocked the care off after the brake failure. So do you know why after restart it worked again?
tobyvivi is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome