Vibration Post-Maintenance - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Focus Forum Forum for the discussion of the Ford Focus

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-08-19, 10:23 AM Thread Starter
Registered User
 
Join Date: Mar 2019
Posts: 2
Vibration Post-Maintenance

I recently replaced my front struts and front brakes and rotors, on my 2010 Ford Focus SE, with some cheaper ones I found online. Afterwards, the ride height was a little higher than normal. There is also a vibration/ shake coming from the front end when accelerating from 0-20mph. It goes away at that speed and only comes back when heavy torque is applied on the highway. It isn’t felt in the steering wheel. Mostly the body. Since the struts were new, I didn’t think it could be those. Maybe I’m wrong. I had an alignment done on the car and the front tires replaced with new ones - separate issue due to cupping from the rear shocks.

Over the few months that followed, I replaced my motor mounts, CV boots and axles, and the lower control arms but none of that helped. It didn’t make the problem better or worse. At this point I’m out of ideas on what could be causing the issue. Any advice on what you would look into next would be highly appreciated!

Zozzy24 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-08-19, 02:59 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 18,533
Re: Vibration Post-Maintenance

If it started after replacing front struts , front brakes and rotors with cheap parts , that's where your problem lies .After replacing front struts the ride height should return back to original after susp. settled back down with a short drive if needed.Only reason it would possibly increase would be if front springs had been replaced as well .Shocks don't normally increase ride height .Could also check strut top mountings , drop link arms and sway bar bushes for vibration .

Never, never, never give up.
R.S.LOGAN is offline  
post #3 of 4 (permalink) Old 03-09-19, 08:47 AM Thread Starter
Registered User
 
Join Date: Mar 2019
Posts: 2
The springs were also new. They came new as a complete assembly. It’s been 8 months since the struts and springs were replaced and the ride height hasn’t settled yet. It’s still the same height as the day they were installed, unfortunately. Is there a way to adjust them or should I look to replace them with OEM parts?
Zozzy24 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 03-09-19, 11:35 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 18,533
Re: Vibration Post-Maintenance

You never mentioned they came new as a complete assembly , I thought it was just the struts . It may have been the wrong units supplied .You should have checked the coil springs as they are colour coded .

Never, never, never give up.
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum

« New Ford Focus ST | - »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
make money quick L Campbell Volvo 0 08-19-05 05:01 PM
Maintenance section of the site Troutman Inline 6 Tech 20 11-18-04 09:52 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome