2007 ranger problem - need advice - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 1Likes
  • 1 Post By R.S.LOGAN
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-19-18, 05:12 PM Thread Starter
Registered User
 
Join Date: Sep 2018
Posts: 2
2007 ranger problem - need advice

I have a 2007 ford ranger. It sometimes wont start and the auto theft light flashes fast......then a while later it will start with no problems. We have taken it to a dealer twice the first time they said it was the computer and changed it....it still happened after that, we took it back to the dealer and they said there is nothing wrong with it. Sometimes when driving the speedometer goes to zero and also the tac and the engine light cones on but then goes off and the speedometer and tac start working. It happens periodically. What could be the problem? Anyone have this problem?

Marshathompson is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-19-18, 06:38 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,909
Re: 2007 ranger problem - need advice

I'd take it back to the dealer and ask for code check. Autozone and O'Reily's will check for free. There should be a code with that. Let us know what you get.

Bert
Bert is offline  
post #3 of 3 (permalink) Old 09-20-18, 01:30 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 18,591
Re: 2007 ranger problem - need advice

Sounds like it could be instrument cluster fault , similar to this model .

http://www.ecutesting.com/ford_focus..._cluster_.html

Common Failure symptoms:

Loss of all instrument cluster functions and lights
Speedometer and rev counter drops to zero
Engine cuts out while driving
Non start
Immobiliser light flashes
Mileage shows dashes
Bert likes this.

Never, never, never give up.
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome