Help with Codes - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-07-19, 10:32 PM Thread Starter
Registered User
 
Join Date: Jan 2019
Posts: 1
Help with Codes

I have a 2001 Ford Ranger Edge 4.0 6cyl and my fuel pump went out. I replaced the fuel pump twice now because the first pump was faulty and the new pump from Carquest seems to be working but giving me PO171 too lean bank 1,174 too lean bank 2, P0232 Fuel Pump Secondary Circuit too high and a PO733 3rd gear incorrect ratio. I suspect the last code is unrelated to the fuel pump but the first 3 codes are. Any suggestions would be great to solve these codes or common problems that you’ve experienced with these. I’ve looked at all the symptoms but I’m trying to avoid the nickel and dime game on a truck with 208k miles.

cubdoge is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-08-19, 03:38 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 18,736
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome