No Blower vent, keeps blowing fuse 27 for Blend door actuator, Climate,2010 Ranger - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-25-18, 12:37 AM Thread Starter
Registered User
 
Join Date: Oct 2018
Posts: 1
No Blower vent, keeps blowing fuse 27 for Blend door actuator, Climate,2010 Ranger

Fuse 27 keeps blowing* on my 2010 Ford Ranger 2.3L, every time I turn key to on even when climate controls are off. This is the fuse for*Blend door actuator, Climate control assembly.
I have disconnected the following:
​​​​​Blender door aculator
Climate control assembly(all the wires for all the controls)
Blower resistor(on blower)
Blower relay
Ac Relay

....and even with all those disconnected and removed fuse 27 keeps blowing. One time I replaced the fuse and blower was working perfectly on all setting , colds,hot ,AC on and off, all vents, defrost, everything. I tried putting a fuse while ignition is on and the blower turns and blows strong but after a second fuse 27 blows again. So WTF!? PLEASE HELP. Any ideas? What should I look for. Why is fuse blowing when everything is disconnected and even relays are removed. WTF! I can't feel my toes

megadrive is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-25-18, 08:18 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,948
Re: No Blower vent, keeps blowing fuse 27 for Blend door actuator, Climate,2010 Ranger

It must be one of the the wires from the fuse panel to the blend door actuator or climate control assembly. They're green with a brown tracer.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome