Need help ASAP! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford SVT Vehicles | SVO Vehicles Forum for discussion of all Ford SVT Vehicles, such as: Ford F150 Lightning SVT, Ford Cobra SVT, Ford Focus SVT, Ford Contour SVT and previous SVO vehicles as well.

 1Likes
  • 1 Post By Bert
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-07-18, 03:12 PM Thread Starter
Registered User
 
Join Date: Jan 2018
Posts: 1
Need help ASAP!

Hey guys I?m new to his forum thought I?d give it a try I own a 2002 Ford lightning bought the truck 2 years ago it never really gave me major issues the truck is fully built. So lately I?ve been having this problem with it where it seems to die out but it doesn?t always do it, the truck idles at about 700 rpms which is average. So when I come to certain stops and gas it again th truck begins to sputter and I start losing power on the gas pedal Sometimes it dies out and at times it somehow manages to get going again. I?ve replaced the mass airflow, idle air control, cleaned out my spark plugs, intake and all & it?s still doing this. Took it to my mechanic a few days back he ran a diagnosis on it and said the fuel pressure was fine so it can?t be the fuel pumps. He also replaced the spark plugs. I also noticed that I drove it for a day or two with the maf disconnected and it ran decent as long as I kept my foot slightly on the gas pedal while at a stop it react fine when I?d take off from a stop. Now That I replaced those parts I?ve noticed that the truck decides to bog out of the random at around 45 mph and starts wanting to die out. I?m no expert and I?d appreciate some guidance thank you guys

Svt_gonzo is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-07-18, 04:32 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,902
Re: Need help ASAP!

If it ran okay with the MAF disconnected, maybe that sensor is defective or a poor connection. Did the tests show any codes?
R.S.LOGAN likes this.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford SVT Vehicles | SVO Vehicles

« Idle When Problem | - »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome