3.8 stalling - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-25-16, 12:32 PM Thread Starter
Registered User
 
Join Date: Feb 2010
Posts: 8
3.8 stalling

I have a 1995 3.8 v6 that after a little time running it will just quit running. And will not start back up for a few hours no check light either. Could it be the fuel pump or something else?

Thanks

maverickfe is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-25-16, 12:42 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 18,597
Re: 3.8 stalling

Checked the crank sensor ? Possible it could be fuel pump but USUALLY when fuel starvation engine tends to splutter a bit before cutting out rather than just cut right out which tends to happen with an electrical fault .

Part 1 -How to Test the Crank Sensor (Ford 3.0L, 3.8L)

Never, never, never give up.
R.S.LOGAN is offline  
post #3 of 4 (permalink) Old 02-26-16, 12:43 PM
Moderator
 
Join Date: Nov 2008
Posts: 1,188
Re: 3.8 stalling

That engine does not have a crank sensor. It still has a distributor. Check the spark
module. It's in the cowl cover on the passenger side above the ECM. Check for spark and
fuel the instant it stalls.
chipset is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 03-09-16, 04:08 AM
Registered User
 
Join Date: Feb 2015
Posts: 182
Re: 3.8 stalling

If TFI ignition could be that module.

Mileage? Super high mile motors can get b-tchy to do that if no compression.
amc49 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > V6 and Hot4 Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome