4.2 Motor surges - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-20-15, 06:51 AM Thread Starter
Registered User
 
Join Date: Jun 2015
Posts: 2
4.2 Motor surges

I just had a Jasper rebuilt motor put in my truck and am having an issue. Noticed shortly afterwards that when I have my trailer hooked up, that when I back into my drive (has a slight incline), that the motor surges at idle or little above as I back in. It is like you have your foot on the gas and then your foot slips off then you give it gas again. When I take off in forward it does it but not as bad. It is the 4.2 engine. As soon as you get up to a little speed it runs great. They cleaned the idle control valve but it still does it. Any ideas?

delgan is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-20-15, 07:39 AM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 7,571
Re: 4.2 Motor surges

Does it idle normal? If so, I'd look at your vacuum first for possible leaks.

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
post #3 of 3 (permalink) Old 06-20-15, 02:31 PM Thread Starter
Registered User
 
Join Date: Jun 2015
Posts: 2
Re: 4.2 Motor surges

Idles fine and we did replace one hose that looked dry. Will check more hoses tonight--no mechanic but will see what I come up with. Thanks
delgan is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > V6 and Hot4 Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome