02 sensor - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar Forum for discussion of all Ford Vans and Ford Mini Vans such as the Ford Aerostar and Ford Freestar.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-21-19, 12:30 PM Thread Starter
Hev
Registered User
 
Join Date: Jun 2014
Posts: 48
02 sensor

I have has the same 02 sensor issues for years. It's bank 2 sensor 2, a few years ago this guy worked on it for months, finally fixed it, said he had to rewire it. A year ago or so the code came up again, both times it was because they sprayed the IAC. So I finally replaced the second one about 2 months ago, code was gone and I got a little more mileage.

A couple weeks ago the engine light went on, it was the same 02 sensor and another, bank 2 sensor 1.
Something about and electrical issue and the remedy was to replace the b2s2. So they did, under warranty, didn't work.

So now they are going through all the wires, this is the second day and say I have to bring it back because they didn't get to all of them.

I wasn't expecting all this and asked how much I was going to be charged, because it's obviously not the sensor.

I'm about to tell him to just bill me and stop the work, I can't pay for all this.

Any ideas what could be going on?

Hev is online now  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-22-19, 04:06 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 7,582
Re: 02 sensor

Year, model, engine and which code(s) will help a bit. Could be anything from a faulty injector to a bad ECM.

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
post #3 of 4 (permalink) Old 03-22-19, 05:48 PM Thread Starter
Hev
Registered User
 
Join Date: Jun 2014
Posts: 48
Re: 02 sensor

Quote:
Originally Posted by CatSkinner View Post
Year, model, engine and which code(s) will help a bit. Could be anything from a faulty injector to a bad ECM.
Sorry. 2000 Windstar 3.8


P0161
P0141
Code P0161 indicates a fault in the B2S2 02 heater electrical circuit for a predetermined period of time.
Solution-Replace oxygen sensor.

B2S2 was replaced, IAC valve was replaced, code came on about 5 weeks after, B2S1 is a new code, never been on before.
Hev is online now  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 03-23-19, 06:32 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 7,582
Re: 02 sensor

There's not much to the heater side of the sensor. It receives 12VDC to start the heater and it's grounded to the distribution ground. I've attached a video for trouble shooting, but checking continuity across the heater should tell you enough.



Capture.jpg

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar


Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
Hev
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Common Ford OBD codes ThunderPhoenix Ford Thunderbird Forum 1 11-17-11 09:50 AM
1997 Mercury Sable will not start pepster91 Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 7 04-09-09 03:00 AM
DTC Codes fordel Ford Focus Forum 8 02-21-09 11:22 PM
98 Windstar Service Engine Light On, No Transmission russ1960 Ford Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar 3 11-24-08 07:19 PM
EEC IV Diagnostic Codes for 89 - 97 Thunderbird/Cougar LunaticSVT Mercury Cougar Forum 0 07-15-03 10:45 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome