93 idi ip shorting out, glow plugs shorting as well - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford F-Series | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F-Series, Superduty and Diesel trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-06-19, 10:40 AM Thread Starter
Registered User
 
Join Date: Nov 2017
Posts: 7
93 idi ip shorting out, glow plugs shorting as well

I really need help guys, my work truck is shorting out the glow plugs. new controller/relay, the fuel solenoid works if you jump it, but the wire going to it doesnt get 12v, and both the spade that goes into the fuel solenoid, and the rear part right next to the solenoid are shorting to ground somewhere. My glow plugs are also all shorting out. I cant find the wire, i have loosened every wire i can think of and retested, and its still grounding. the 2 spades on the pump for the solenoid and the back one right next to it are both shorting to ground even when unattached to their wires. HELP! please! 1993 f250 turbo diesel zf5 if that matters. Also my wts light wont come on even after my brand new glow plug controller/relay.

chriswilhelm is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-07-19, 05:57 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 7,580
Re: 93 idi ip shorting out, glow plugs shorting as well

Do me a favor and define "shorting to ground", as in blowing fuses?

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
post #3 of 6 (permalink) Old 03-08-19, 03:30 PM Thread Starter
Registered User
 
Join Date: Nov 2017
Posts: 7
Re: 93 idi ip shorting out, glow plugs shorting as well

I guess what i mean is that the fuel shutoff solenoid wire and the wire right behind it on top of the IP are no longer getting 12 volts. the spade connectors that the wires attach to, read a continuity between any ground on the truck and them, and im pretty sure since they receive 12 volts, they should not be connected to a ground, and yet, they are.

I would love to know where the 2 wires that connect on top of the ip (fuel shutoff solenoid, and the one behind it, no idea what it does) are supposed to receive their power from? The solenoid on the passenger firewall? directly from the ignition? Im trying to back track without ripping my wiring up too much. I was hoping someone would be like "look at the ______ relay, or ______ solenoid, that is where those 2 wires get their power from" I hope i am being as clear as possible, sorry if i am not, i really appreciate your response!

My glow plug light worked for literally 1 second after i installed my new glow plug relay/module, then i heard a click, and now im not getting glow plug power, or power to those two wires on top of the ip.
chriswilhelm is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 03-08-19, 05:15 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 7,580
Re: 93 idi ip shorting out, glow plugs shorting as well

First, that is how electricity works, power comes from the source (battery, alternator, etc) goes through the load, then to ground. Sometimes the ground is from a dedicated wire, other times it's through the body of the load. I can't make a guaranty, but I'm pretty sure that the glow plugs are grounded that way, but there should be some sort of resistance.



That doesn't rule out a short, though. Generally, what I'll do to isolate a short to ground is disconnect the wires that supply devices grounded through the body and disconnect the ground wire to the components with a designated ground and start hunting. Having a wiring diagram helps, unfortunately, I can't help you with that.



https://www.wikihow.com/Test-Glow-Plugs

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
post #5 of 6 (permalink) Old 03-08-19, 07:11 PM Thread Starter
Registered User
 
Join Date: Nov 2017
Posts: 7
Re: 93 idi ip shorting out, glow plugs shorting as well

Ok, can you answer me this: With the ip electrically disconnected from everything (theres like 3 wires that go to it total in my case) should there be continuity between the spade connectors on it and the body of it which is grounded to the rest of the truck? its like its internally shorted or something. Theres a little isolator underneath the spade connector on the ip that should be isolating it from the grounded body of the ip. Right?
chriswilhelm is offline  
post #6 of 6 (permalink) Old 03-09-19, 07:59 AM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 7,580
Re: 93 idi ip shorting out, glow plugs shorting as well

Well, what is the purpose of the wire to the insulated spade connector. Not sure where the fuel heater is, but if it ties into the pump, you will need an insulated connector on the line side of the pump. You really need a schematic. I found an electrical schematic for the 6.0L, it showed either 5 wire or 3 wire, depending on where the grounds combined.

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-Series | Ford Super Duty | Ford Diesel


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Glow plugs or not riss6270 Ford F-Series | Ford Super Duty | Ford Diesel 1 03-04-08 05:31 AM
Mondeo, glow plugs....? just_steve Interior | Electrical | ECU 1 05-08-06 01:50 AM
Re: 300Tdi - Slow start in cold weather - New glow plugs needed? Andrew Renshaw Land Rover 0 01-16-06 04:01 AM
300Tdi - Slow start in cold weather - New glow plugs needed? Judith Land Rover 24 12-31-05 10:03 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome