C4/C10 Transmission trouble - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-02-16, 05:54 PM Thread Starter
Registered User
 
Join Date: May 2016
Posts: 2
C4/C10 Transmission trouble

Need some help. I have a 1974 ford v8 (302) stationwagon. I recently took out the tired c4 and replaced it with a c10. My problem is it is now changing gears late.
1-2 .....40km
2-3.....80km
I'm getting plenty of suction from the intake manifold which is great. My thoughts are with the vacuum unit. C4 and c10 units are slightly different. C4 vacuum unit is hollow in the end. The c10 vacuum unit has a screw in the end which is wound out as far as possible before there is no tension left on the screw without actually removing it. I took the vacuum unit from the c4 and put it in the c10 and it dropped to 35 km.
Could I get some feedback please as to having the gears change much earlier.
Cheers

havachat9 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-03-16, 05:21 AM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 7,571
Re: C4/C10 Transmission trouble

Could be just a vacuum leak, try changing the line and check the remaining vacuum lines in the car.

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
post #3 of 3 (permalink) Old 07-10-16, 03:44 AM Thread Starter
Registered User
 
Join Date: May 2016
Posts: 2
Checked the line for air leaks and found none. Might take it the local mechanics and get them to look. Shouldn't take long to look at......hopefully. Lol.
havachat9 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Classic Fords > Classic Fords > Classic Falcons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome