Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars

-   E-Series Falcons (https://www.fordforums.com/f647/)
-   -   Power issues with the EA Falcon... please help me! (https://www.fordforums.com/f647/power-issues-ea-falcon-please-help-me-83956/)

ssj_jaypee 09-28-04 01:19 AM

Power issues with the EA Falcon... please help me!
 
Hi all,

I'm new here and I bought myself a 1990 30th Anniversary model EA Falcon GL a few days ago but have been having some problems with it and hopefully could get some help from anybody here whos got any info I could use.

Its got the 3.9lit CFI motor and 4spd auto but I suspect theres something up with the engine because I cant seem to get any power from the car at all when I plant my foot down.

Its supposed to have 120kW and 311Nm torque from the specs I've read but it feels like I've got only half of that. Its got no pickup in any gears, I cant even beat an econobox Corolla in a drag race.

I'm not sure what the previous owner has done or rather not done to keep this falcon in shape but can anybody give me any tips what I could do to get it running at optimal performance again?
I do know that its roadworthy and only had a serviced checkup done to it 6months ago.
I've tried a few things already like changing the air filter and draining and flushing the radiator and putting in new coolant as well as installing a new battery.

If anybody could give me a helpful hand it would be much appreciated.
I'm just a little disappointed at the moment with the performance my falcon is doing.

Thanks!

Heritage 09-28-04 01:26 AM

Re: Power issues with the EA Falcon... please help me!
 
I would bet my left nut that its the fuel pump, My step-daughters car was doing exactly the same thing, had no power at all, put the foot down and it would go slower.
Replaced the fuel pump and everything was fine.

p4r4l3l 09-28-04 01:57 AM

Re: Power issues with the EA Falcon... please help me!
 
weird that they put 4speeds in a cfi model lol

Brent79 09-28-04 02:19 AM

Re: Power issues with the EA Falcon... please help me!
 
Could be anything really... somethings to check tho. If your car is running (idling) bad or hesitating while accelerating, then its probable to be a fuel delivery problem. As said, check the fuel pump / filter or get a pressure test done. Also maybe the injectors. Try getting em cleaned or replaced. Hows the engine temp? If its running hot, could be an exhaust blockage. If its bad enuf, u will hear it hissing. Somethings to try out.

Cheers

Brent

MADNC_8 09-28-04 05:20 AM

Re: Power issues with the EA Falcon... please help me!
 
sounds like a snapped or streched throttle cable.

you didnt say it was running like a dog, just that it deosnt feel powerful, a streched throttle cable just wont allow the throttle butterfly to open fully, so it'd be like your just at part throttle when you think your at full throttle.

InitialD 09-28-04 05:39 AM

Re: Power issues with the EA Falcon... please help me!
 
When i bought my EA it was very sluggish, and as wayne (madnc_8) said, it was my accelerator cable. Visited Pickapart and got a real good one for $10. Suddenly my car seems to have about 40% more power, meaning that i only have to press down 20% of what i did before and it takes off.

SPHELL 09-28-04 05:53 AM

Re: Power issues with the EA Falcon... please help me!
 
im tipping your car doesn't have cruise control so if you look on the throttle body where the accelerator cable joins up, there should be a free spot underneath it where the cruise control cable usually goes. just disconnect your accelerator cable and move it down to the cruise control linkup point. This will take up the slack in the accelerator cable and make it feel much tighter....and it will also open the throttle more when you put your foot down. Then you don't have to buy a new cable.

other than that it could be heaps of things. dirty fuel filter, fuel pump on it's way out, cat convertor could be blocked, injectors could be dirty, cyls down on compression, etc etc

can you give us a more detailed description of what the car is actually doing like if its mis-firing, got a flat spot etc etc.

MADNC_8 09-28-04 05:58 AM

Re: Power issues with the EA Falcon... please help me!
 
doug, correct me if im wrong, but i dont believe the CFI throttlebody has the provisions for the cruise control hookup, thats why "Spope" had to make a small linkage to connect his cable for cruise

Rmyers 09-28-04 06:10 AM

Re: Power issues with the EA Falcon... please help me!
 
I would put my money on a stretched accelerator cable...

ssj_jaypee 09-28-04 06:30 AM

Re: Power issues with the EA Falcon... please help me!
 
Hey everybody thanks for all the help so far.
I'm not very mechanically minded but I'll try and explain anything you need to know as best as I can.

The car isnt misfiring as far as I know, there arent any 'bangs' or weird noises I can hear coming from it.
I dont know what you mean by a 'flat spot' but it seems to accelerate steadily most of the time but the falcon wont seem to accelerate any harder nor go much faster when I put the foot to the floor.
I do occassionally get sudden unexpected power urges while I accelerate but that could be due to the gear change. Its hard to tell when its changing gear because the engine just doesnt rev very high at all.

The previous owner also told me that he recently changed the middle part of the exhaust system and the car is very quiet.
It starts fairly well but occassionally idles awkwardly as if its going to conk out.
The engine temp used to be pretty bad fluctuating alot into the high temp area but since I got a new air filter and flushed the radiator as well as putting in brand new coolant the engine temp runs lower although will rise a little higher than normal every now and then.

I have no idea where my throttlebody or accel cable is nor what they look like so I cant check that out.
With the possible fuel pump/filter/injectors as the problems, is there any way I can inspect and replace them myself? As I'm not very good with the mechanical side of cars.

If theres anything else you need to know I'll try and explain it as best I can.

Thanks again!


All times are GMT -7. The time now is 05:24 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome