Power issues with the EA Falcon... please help me! - Page 2 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 79 (permalink) Old 09-28-04, 06:30 AM
Pimpin the chrome
 
InitialD's Avatar
 
Join Date: Aug 2004
Location: Melbourne
Age: 34
Posts: 771
Re: Power issues with the EA Falcon... please help me!

CFI EA's never had Cruise control in them. all Ghia's that had them had MPFI and the aftermarket cruise controls connected onto the accelerator cable


1991 Ford Falcon EA 30th Anniversary

EF head | EF XR6 Cam |Pacemaker 3320(?) extractors | Hiflo cat
3:23 | Auto | XH Snorkle | Thermos | 2.5" Mandrel Exhaust
Full NC2 Sportsman Interior inc Dash & Electrics
Custom Clear Tailights and Garnish
Sprint kit | Moffat front bar (soon) | king lows
FTR Chrome Rims | Driving lights | Custom ED Mesh grill
Pioneer of the Clear ED tailights
InitialD is offline  
Sponsored Links
Advertisement
 
post #12 of 79 (permalink) Old 09-28-04, 07:14 PM
Vroom vroom
 
spope's Avatar
 
Join Date: Feb 2004
Location: Io
Age: 38
Posts: 233
Re: Power issues with the EA Falcon... please help me!

Correct. There is no linkage on the cfi throttle body for an additional cable. The only link is for a kickdown cable, clearly not applicable here.
I'd suggest definately trying another throttle cable, they are easy as to remove, just pull off the aircleaner assembly and you'll see the connection. There should be no slack in it at all. If there is, it'll need to be replaced.
Do you know if it is running rich? Ie, any black stuff out of the exhaust?
I'd try as a first step whacking a bottle of injector cleaner in your tank and see what happens.

EA GL-Ghia pseudo operator
3.9 MPFI converted 4 speed
2.5 inch exhaust
NC Ghia interior (except rear trims)
Fairmont audio (with 4 speakers)
Cruise control
S-pac cluster with white dials
Trip computer and Fairmont interior lighting.
Half wired Ghia BCM.
spope is offline  
post #13 of 79 (permalink) Old 09-28-04, 07:29 PM
Registered User
 
Join Date: May 2004
Location: Perth
Age: 35
Posts: 80
Re: Power issues with the EA Falcon... please help me!

spope your comment about running rich..... black stuff out of the exhaust. mine does that. its like sooty stuff, no smell with a consistency of water but black as. only happens when i start..... is it moisture build up or something else. ran some injector cleaner through it the other day. should i be looking into it?

also with this dudes ea. obviously automatic.... could it be the bands need adjusting. reading the ford manual last night coz my autos playing up and bands that need adjusting cause dead spots, lack of power, sluggish acceleration etc.

cheers
ian_d is offline  
Sponsored Links
Advertisement
 
post #14 of 79 (permalink) Old 09-29-04, 01:42 AM
E-Series wagon owner
 
mad_ea_spac's Avatar
 
Join Date: May 2003
Location: dandenong nth
Age: 31
Posts: 1,929
Re: Power issues with the EA Falcon... please help me!

Quote:
Originally Posted by SPHELL
im tipping your car doesn't have cruise control so if you look on the throttle body where the accelerator cable joins up, there should be a free spot underneath it where the cruise control cable usually goes. just disconnect your accelerator cable and move it down to the cruise control linkup point. This will take up the slack in the accelerator cable and make it feel much tighter....and it will also open the throttle more when you put your foot down. Then you don't have to buy a new cable.

other than that it could be heaps of things. dirty fuel filter, fuel pump on it's way out, cat convertor could be blocked, injectors could be dirty, cyls down on compression, etc etc

can you give us a more detailed description of what the car is actually doing like if its mis-firing, got a flat spot etc etc.
you recon this would work with an perfectly normal mpi? i'm just thonking i can get more get up and go out of it trying that mod

1994 ED Ford Falcon Gli wagon, polynesian green, 4speed auto, dual fuel, spac cluster, 3.27ss diff,pioneer DEH3600 head unit, trip computer, ED fairmont grille, EF T-bar

Mods to come: 2.5'' lukey cat-back mandrel bent exhaust with 1 resonator and 1 straight thru muffler, EF cam, Clear indicatros all round, AU3 XR snorkel, 17" Keizzer rims, EDxr front,12"sub,sports wheel

In Progress: EF door trims



Pics Here: www.edwagon.tk
mad_ea_spac is offline  
post #15 of 79 (permalink) Old 09-29-04, 02:31 AM
Green's Tuff!
 
Heritage's Avatar
 
Join Date: Mar 2003
Location: Wonthaggi, Victoria
Age: 45
Posts: 802
Re: Power issues with the EA Falcon... please help me!

4 Speed Auto's don't have bands, they are electronically controlled.
Heritage is offline  
post #16 of 79 (permalink) Old 09-29-04, 05:00 AM
Chasing down oil leaks...
 
Axeman82's Avatar
 
Join Date: Nov 2001
Location: nearly Kingaroy, Qld.
Age: 37
Posts: 836
Re: Power issues with the EA Falcon... please help me!

Also in the mechanical autos when the bands get loose the car still revs but doesn't pick up at all - and if it gets bad enough it will slip out of gear and rev, rev, rev, clunk back in and go. My 3psd does this when i go fast out of a corner. But obviously not applicable here.

I'm assuming that you have driven other cars to compare the sluggish feel to? But as with everyone i'd say the throttle cable, also check that it isn't bent or frayed which can cause it to stick.

Welcome to the Forums.

Dan..

1988 EA Falcon Pearl Green
Head gasket replacement count - 1



Axeman82 is offline  
post #17 of 79 (permalink) Old 09-29-04, 07:00 AM
 
Join Date: Jan 2003
Location: Melbourne, Australia
Age: 33
Posts: 5,083
Re: Power issues with the EA Falcon... please help me!

Quote:
Originally Posted by mad_ea_spac
you recon this would work with an perfectly normal mpi? i'm just thonking i can get more get up and go out of it trying that mod
Unless your cable is streched it'll do nothing but reduce the control you have over the throttle.
psycho chicken is offline  
post #18 of 79 (permalink) Old 09-29-04, 07:51 AM
Registered User
 
Join Date: May 2004
Location: Perth
Age: 35
Posts: 80
Re: Power issues with the EA Falcon... please help me!

it was a 4 speed too. my bad i did know that
ian_d is offline  
post #19 of 79 (permalink) Old 09-30-04, 02:12 AM
WHAT THE?
 
SPHELL's Avatar
 
Join Date: May 2002
Location: Vicroads inspection bay
Age: 38
Posts: 925
Re: Power issues with the EA Falcon... please help me!

Quote:
Originally Posted by MADNC_8
doug, correct me if im wrong, but i dont believe the CFI throttlebody has the provisions for the cruise control hookup, thats why "Spope" had to make a small linkage to connect his cable for cruise

ah yeah sorry guys i didn't read the thread properly. I just assumed it was mpfi....
SPHELL is offline  
post #20 of 79 (permalink) Old 09-30-04, 10:41 PM Thread Starter
Registered User
 
Join Date: Sep 2004
Posts: 44
Re: Power issues with the EA Falcon... please help me!

Hey everybody, well I went out today and bought myself a new fuel filter and some fuel doctor liquid.

Its not the transmission fluid I dont think cause I checked it and its still got plenty.
This fuel doctor bottle I bought apparently cleans out your fuel system (tank, injectors, filter, etc) of any rubbish that may be in there so that could also help me but I havent tried to put in it yet cause I need to add it when I go for a fuel refill.

Now, just need some help with installing the fuel filter.
I basically have almost no idea how to install one. Infact I dont even know where the fuel filter is on my car!
Could anybody please give me the run down on how I can replace my old filter with this new one?

I also havent been able to check my accelerator cable or throttle body? Where is it located and how would I be able to adjust it if it is loose or damaged and the main cause why my Falcon is running poorly?

Thanks again!
ssj_jaypee is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
EA Falcon VS AE92 Corolla SX Ruger E-Series Falcons 17 04-19-07 03:05 AM
The Falcon - A Brief History RPO83 Australian Falcons 5 08-06-04 12:48 AM
Pukekohe - Practice 1 & 2 - Results - Spolier josh.c Ford Racing Across the Globe 48 05-06-04 04:03 PM
Territory Launch (Comprehensive) RPO83 Territory 25 05-03-04 04:56 AM
AUS: Tough Truck On Show In Sydney RPO83 Ford Worldwide News 0 10-15-03 06:05 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome