Power issues with the EA Falcon... please help me! - Page 4 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 79 (permalink) Old 10-11-04, 03:51 AM Thread Starter
Registered User
 
Join Date: Sep 2004
Posts: 44
Re: Power issues with the EA Falcon... please help me!

Oh ok. I didnt know it goes into the dipstick tube, I always thought it worked similar to putting oil in where it had a separate opening.

By the way I forgot to mention, something has been really bothering me lately about my car.... the engine temperature. The temp guage keeps going quite high after using the car for a certain period of time.
I mean I had this problem when I first got the car but after I changed the coolant and air filter the engine ran quite cool and seemed to stay in the lower normal engine temp area.
But up until recently now my engine temp guage keeps going higher up in the normal area almost hitting the dangerous level.
I changed the oil, oil filter and spark plugs in an attempt to rectify this problem but it still gets hot.

I mean the engine temp runs quite cool for around 10 mins but then starts getting hot really quick after that. The coolant is still full in the radiator and the fan is working so I have no idea why this is happening.

If anybody has any ideas it would be greatly appreciated.

ssj_jaypee is offline  
Sponsored Links
Advertisement
 
post #32 of 79 (permalink) Old 10-11-04, 03:58 AM
Chasing down oil leaks...
 
Axeman82's Avatar
 
Join Date: Nov 2001
Location: nearly Kingaroy, Qld.
Age: 37
Posts: 836
Re: Power issues with the EA Falcon... please help me!

Possibly a stuffed thermostat?

Does it just keep going up or does it go up and down, up and down?

Dan..

1988 EA Falcon Pearl Green
Head gasket replacement count - 1



Axeman82 is offline  
post #33 of 79 (permalink) Old 10-11-04, 04:00 AM
Registered User
 
dpk83's Avatar
 
Join Date: Apr 2003
Location: Melbourne
Age: 35
Posts: 1,175
Re: Power issues with the EA Falcon... please help me!

try replacing your thermostat.. Mine did the same thing, but opposite. It wouldn't heat up! They're cheap, and also easy to replace.

also, check your oil cap isn't looking milky...
dpk83 is offline  
Sponsored Links
Advertisement
 
post #34 of 79 (permalink) Old 10-11-04, 04:01 AM
Registered User
 
dpk83's Avatar
 
Join Date: Apr 2003
Location: Melbourne
Age: 35
Posts: 1,175
Re: Power issues with the EA Falcon... please help me!

lol, Axeman.. What do they say about great minds.
dpk83 is offline  
post #35 of 79 (permalink) Old 10-11-04, 04:10 AM Thread Starter
Registered User
 
Join Date: Sep 2004
Posts: 44
Re: Power issues with the EA Falcon... please help me!

Quote:
Originally Posted by Axeman82
Possibly a stuffed thermostat?

Does it just keep going up or does it go up and down, up and down?

Dan..
It fluctuates. Starts off very cold for around 7 mins of driving then starts going up slowly till it gets pretty high but it does go down and up, sometimes it will go from being really hot to more cooler.
Its not the thermostat playing up because when the guage indicates the engine temp is really hot I park the car and can smell something burnt coming from the engine bay so I'm guessing it really is hot.
ssj_jaypee is offline  
post #36 of 79 (permalink) Old 10-11-04, 04:33 AM
"Steve has a car?"
 
Rmyers's Avatar
 
Join Date: Jun 2002
Location: Melbourne
Age: 36
Posts: 2,207
Re: Power issues with the EA Falcon... please help me!

Quote:
Originally Posted by ssj_jaypee
It fluctuates. Starts off very cold for around 7 mins of driving then starts going up slowly till it gets pretty high but it does go down and up, sometimes it will go from being really hot to more cooler.
Its not the thermostat playing up because when the guage indicates the engine temp is really hot I park the car and can smell something burnt coming from the engine bay so I'm guessing it really is hot.
Do you know what a thermostat is?? Sounds like you think it's a sensor of some sought. It's actually like a valve that opens and closes depending on engine temperature. It stops the water circulation and periodically releases it back into the radiator so that the engine can warm up rather than running cold all the time. When a thermostat is buggered, the water can often be released "too late" if you will, and causes the engine to get into the "danger" zone before it recirculates the water and the temp goes back down, hence you get fluctuating temperature. So i would put my money on a buggered thermostat....

The burning smell could simply be a slight oil leak burning on the engine block or similar...

Rmyers is offline  
post #37 of 79 (permalink) Old 10-11-04, 04:54 PM
EA-S MPI 5-Speed
 
BoZZa17's Avatar
 
Join Date: Sep 2003
Location: Hoppers Crossing, VIC
Age: 33
Posts: 403
Re: Power issues with the EA Falcon... please help me!

check that your headgasket hasnt gone. (look for milky white crap under oil filler cap) and yeah check the thermostat. new one isnt expensive and its good peice of mind to know if u get a new one u wont have that issue for a while again

BoZZa17 is offline  
post #38 of 79 (permalink) Old 10-11-04, 05:16 PM
'90 EA-II Fairmont
 
SileNceR's Avatar
 
Join Date: Aug 2003
Location: Warrnambool, VIC, Aust.
Age: 34
Posts: 572
Re: Power issues with the EA Falcon... please help me!

accellerator/throttle cable is easy...

engine side remove the retaining clip with some needle nose pliers (Dont lose it!), unscrew the plastic part (at the end of the spring) and remove that end from the throttle body area

in car, undo the nuts holding the accel pedal on (13mm i think? you may need to put the socket on then the extension as the bolts are fairly long) pull out accel pedal, then using pliers again remove the black and yellow plastic clips from their retainers...

then pull the whole cable out by pulling the engine side into the car thru the firewall.

Installation is the reverse or removal, put it all in from the inside of the car..

Rosewood EAII Fairmont 02/90. MPFI 3.9L (formerly CFI), 4spd BTR Auto. Skyline geared 3.45g open center 28 spline 4 pinion differential & axles. 2 1/2" Cat Back Exhaust. King Super Low Springs. Sound: Equalization and amplification by Clarion; Head unit by Sony, Front, Rears and Sub by Pioneer. Planned mods - t5, Extractors, Painting Grey Strips and new front and rear bar.
SileNceR is offline  
post #39 of 79 (permalink) Old 10-15-04, 09:40 PM
Registered User
 
Shortcircuit's Avatar
 
Join Date: Sep 2004
Posts: 18
Re: Power issues with the EA Falcon... please help me!

If your car is running hot then its gonna be a pig to drive and is gonna guzzle fuel as well , I'd look at the radiator first , quite possibly blocked . If your oxy sensor is pretty old it might be a good idea to replace that as well . Nothing sucks off power more then a car thats running hot and rich.
Shortcircuit is offline  
post #40 of 79 (permalink) Old 10-16-04, 11:32 PM Thread Starter
Registered User
 
Join Date: Sep 2004
Posts: 44
Re: Power issues with the EA Falcon... please help me!

Hey fellas whats been happening?

Okay today I finally got around to replacing the thermo stat. But not before I took the car out for a drive so I'm not sure if it has done anything because the engine temp still gets quite hot.
I'll have to find out tomorrow whether getting the new thermo stat actually worked.
If not, what else could be the problem? The radiator shouldnt be blocked as I flushed it out with a hose not long ago.

Whats an oxy sensor and how do I replace one?

Cheers!
ssj_jaypee is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
EA Falcon VS AE92 Corolla SX Ruger E-Series Falcons 17 04-19-07 03:05 AM
The Falcon - A Brief History RPO83 Australian Falcons 5 08-06-04 12:48 AM
Pukekohe - Practice 1 & 2 - Results - Spolier josh.c Ford Racing Across the Globe 48 05-06-04 04:03 PM
Territory Launch (Comprehensive) RPO83 Territory 25 05-03-04 04:56 AM
AUS: Tough Truck On Show In Sydney RPO83 Ford Worldwide News 0 10-15-03 06:05 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome