98 Ford Contour Electrical Issue - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-25-16, 09:48 AM Thread Starter
Registered User
 
Join Date: Sep 2016
Posts: 1
Lightbulb 98 Ford Contour Electrical Issue

I have a 1998 Ford Contour GL 2.0 with 114,000 miles The carrecently developed an electrical issue. The first noticeable sign was the gauges quite working. The dash lights still work as do the blinkers, but nothing else on the panel. Also, and this may be unrelated, but the a/c stopped cooling. It still blows, but hot and it was ice cold before. My daughter continued to drive the car for a day or so and then the battery died. I replaced the alternator, like a nitwit without testing it first. It wasn't bad. Now we've also realized the brake lights aren't working. As long as the battery is fully charged, the car runs and drives just fine, however, no brake lights, gauges, a/c or warning lights. The battery will not stay charged while driving the car, so I'm certain there's a heavy drain on it.

I'm stumped.

shane98 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-25-16, 10:11 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,948
Re: 98 Ford Contour Electrical Issue

Have you checked all the fuses, under the hood and inside?

Bert
Bert is offline  
post #3 of 3 (permalink) Old 09-25-16, 11:16 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 18,735
Re: 98 Ford Contour Electrical Issue

Have you load tested the battery and checked alternator output when running on car ? If you have a dud / weak cell in battery it wont hold a charge and alternator will be battering it's brains in trying to keep up .

Never, never, never give up.
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome