Ford Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I'm a tech and I have a 2004 6.0 no start 120k no codes
I traced it down to the lpop. I pull the cover off the lpop no oil is being pulled through picktube. no oil in pump. I found the regulator stuck open . this would cause it to not pull oil at all right? or would it still pull some oil ? gears look ok! minimal scarring. Also I pulled the regulator but only spring came out (spring shot out) orifice is still stuck in front cover afraid of scarring it up with a pick any ideas on safely removing said stuck regulator?
Thanks
 

·
Super Moderator
Joined
·
7,632 Posts
From what I can tell, a stuck regulator can cause the oil loss, once fixed, it looks like you'll need to prime the pump as well.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I thought it might break the suction its getting a cover& gear kit but I need it to bust off on what I got so I can make sure it doesn't have other problems like a hpop out or rod knock
 

·
Super Moderator
Joined
·
7,632 Posts
Unfortunately, I'm not as familiar with the modern diesels, I'm hoping someone else will pipe in with a little more experience.
 

·
Registered
Joined
·
1,959 Posts
Have replaced regulators on the 6.0. Sometimes just a bad one. Other times debris will cause it. Will need to see if something went through the pump. Usually if something did it turns out to be a needle bearing out of a lifter that's coming apart.
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
3 Participants
r-clar
Ford Forums
Ford Forum is a community to discuss all things Ford. Check out our discussions on the Ford Escape, Mustang, Edge, F-150, Raptor, Explorer, Focus, Fusion, Fiesta and more!
Full Forum Listing
Top