Ford Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i have just installed a new used 250 cross flow engine into my brothers xf ute auto with power steering the engine came from a 79xd with a pionts distributer and cast head..
I have replaced the timing chain and water pump and gaskets where needed
Installed original alloy head and manifolds..
Motor is running with the timing adjusted at feel same as the idle
the dip stick was modified in the xd engine and i am not sure of the levels to reinstall new oil into engine.
SO i am needing factory timing specs>>>>>>>????
Idle speed for the Auto>>>>>>>>>>>????????
total engine oil capacity including filter>>>>>>>>>>>?
any help would be more than helpful thanks
the engine hass 197000klms on the odo,
I also snaped the bolt in the powersteer pump lock bolts what a pain i am getting another tommorrow. I need to degrease its getting oily in the bay but it was clean when i started :beerbottl :hy:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
never mind silly me around 4& 1/2 ltrs of 20w 50 motor oil
in neutral around 625 > 765 rpm
and pritty sure @ TDC such a simpler motor
 

·
Registered
Joined
·
917 Posts
mehumming said:
i have just installed a new used 250 cross flow engine into my brothers xf ute auto with power steering the engine came from a 79xd with a pionts distributer and cast head..
I have replaced the timing chain and water pump and gaskets where needed
Installed original alloy head and manifolds..
Motor is running with the timing adjusted at feel same as the idle
the dip stick was modified in the xd engine and i am not sure of the levels to reinstall new oil into engine.
SO i am needing factory timing specs>>>>>>>????
Idle speed for the Auto>>>>>>>>>>>????????
total engine oil capacity including filter>>>>>>>>>>>?
any help would be more than helpful thanks
the engine hass 197000klms on the odo,
I also snaped the bolt in the powersteer pump lock bolts what a pain i am getting another tommorrow. I need to degrease its getting oily in the bay but it was clean when i started :beerbottl :hy:
4.5 litres with filter , once you have it running idle should be about 700 to 750 rpm , drive up a good slope in top and if pings back the ginition off a little .
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
thanks sounds like thats the go, i might have to remove the distributer again as i have not anymore retard left ..
as for a slope all i could do as for i have no dyno and not really worried bout the graph that much is hope the dwell angle is consitant throughout its rev range..
engine seems strong little rough on idle but i think its still a little advance..
i installed new oil and filter, am going out to yard tommorrow to find a used power steer pump as i snapped the holding bolts in there position,, silly me trying to remove the pulley removed the pulley with the drive shaft from the pump.. :shh:
from day one i have noticed that the pulley had not ever aligned properly with the balancer , this time its going to be fixed ..
 

·
Registered
Joined
·
15 Posts
Timing for the engine is 8-10 degrees btc

depending on the condition of the engine you may have to go to 6 degrees to stop pinging.

If you dont have a timing light make sure you set your static timing before starting the car.
 
1 - 5 of 5 Posts
Top