Ford Forums banner

1 - 9 of 9 Posts

Registered
Joined
10 Posts
Discussion Starter · #1 ·
I've changed the spark plugs, wires, dizzy, rotor, fuel filter, cut the muffler, and put a CAI using an adapter that connects to the stock MAF sensore housing then used the stock rubber intake tube. Put a pod filter on the valve cover vent and still waiting for a pod filter to go onto the black cylindrical thing in the front of the engine bay (evap system?) I have left the intake temp sensor unplugged as it has no where to connect to, unless I drill a hole through the rubber intake tubing 馃馃.

So after all that when at park I can rev high enough for the shift light to come on, when driving it doesn't hit a high enough rpm for that light to come one but instead it limits my speed to 15 in first, and no more then 30 in second.

Do I need to advance timing or check fuel injectors? I plan on drilling that hole just so the intake air temp sensor can plug in.

Never had problems like this with other cars so not sure what the issue is, ill check the dizzy to make the firing order is right.

Now my dad did try and start the car once when I had it the spark wires wrong, could that have affected anything.
 

Super Moderator
Joined
9,333 Posts
So it didn't do this before the CAI install? It sounds like whatever that adapter is, is messing with the MAF. Just for shots and giggles (they won't let me say "sh**") hook the air temperature sensor up and temporarily tape it someplace to see if things improve. When you have this many possibilities, you have to rule out the mods one by one.
 

Registered
Joined
10 Posts
Discussion Starter · #3 ·
So it didn't do this before the CAI install? It sounds like whatever that adapter is, is messing with the MAF. Just for shots and giggles (they won't let me say "sh**") hook the air temperature sensor up and temporarily tape it someplace to see if things improve. When you have this many possibilities, you have to rule out the mods one by one.
Did some research and I think I may need to reset the ECU so after I do that I'll try what you said
 

Registered
Joined
10 Posts
Discussion Starter · #4 ·
Reset the ECU taped the temp sensor so its not flying around, gave her the Ole Italian Tune, and its starting to drive normal and hit max revs again, I just need to let her whine out on the highway and it should be G2G.
 

Registered
Joined
5 Posts
I am Glad You did this I am working on something similar with the 2nd Gen 1990 Model LS Auto I already but much of the Exhaust and Intake Stuff. Might have to get it pieced Together Custom by Another Professional though for like the Welding or Housing Situations. Anyways I just got This Car recently so looking into all of this as well. It seems like a straight on in and straight out is better than how it was designed. It had like a Down Spout going in as well as out. Do You have any Pics?
 

Registered
Joined
10 Posts
Discussion Starter · #6 ·
I am Glad You did this I am working on something similar with the 2nd Gen 1990 Model LS Auto I already but much of the Exhaust and Intake Stuff. Might have to get it pieced Together Custom by Another Professional though for like the Welding or Housing Situations. Anyways I just got This Car recently so looking into all of this as well. It seems like a straight on in and straight out is better than how it was designed. It had like a Down Spout going in as well as out. Do You have any Pics?
 

Registered
Joined
10 Posts
Discussion Starter · #7 ·
Just waiting on the EVAP canister filter, but do you mean the exhaust manifold? I was gonna get a 2.3 flange from a ranger or another exhaust manifold for a tempo and try and cut a flange from that, idk we will see.

As for now I need to get to a muffler shop cut the cat straight pipe it and get this magnaflow put on I got for free.
 

Registered
Joined
5 Posts
Just waiting on the EVAP canister filter, but do you mean the exhaust manifold? I was gonna get a 2.3 flange from a ranger or another exhaust manifold for a tempo and try and cut a flange from that, idk we will see.

As for now I need to get to a muffler shop cut the cat straight pipe it and get this magnaflow put on I got for free.
Awesome I am looking forward to that because I am designing something as well I pretty much following AP Design except I am going for a Straight On & Straight Out Setup. I got the Intermediary Pipe with Clamps plus a Hangar w/Resonator along with Another Muffler plus a Tip. Aside from this I installed K&N Intake plus a Wider Straight on Silicone Intake from Mishimoto. The Other Exhaust Parts are Jones/Walker. I added some Additives since I got this over a Month ago. I also got the K&N Fuel/Oil Filters that I need to put on. I was interested in Magnaflow Cat as well seeing about getting that. Btw I probably am going to off some Parts since I found places where I can get replacement Parts that seem more Modern and perhaps better design like some Site selling Fenders with Vents or even Carbon Fiber Hoods/Trunks. I was also working around that weird Fabric under the Hood. Mine is getting all ratty after all this time. 1st Vehicle I have had with that gross design. Anyhow I am interested in seeing Your Updates for this too. I forgot to say the Tips I have are DC Sports one of which is supposed to fit the Small OEM Piping. I just want better Acceleration & more responsiveness really before having to Engine Swap which I am talking to People about that as well.
 
1 - 9 of 9 Posts
Top