Ford Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Alright, so hello! I'm Jacob.
I'm new here, like BRAND new my guy.

Had a guy recently swap a 2000 Mustang gt 4.6 into my 1999 crown vic. The base model. And I've got some issues.

It sounds and feels like a misfire.
I've got stumbling, loss of power, and that kind of off-beat sounding exhaust sound.

I've replaced spark plugs, coil packs, injectors, and today I replaced the o2 sensors. I thought maybe a catalytic converter was clogged, but I can blow air through it with my mouth and it comes out the other side.

I cannot, for the life of me, figure out what is the problem.
No check engine light... No codes...
 

·
Registered
2000 grand marquis ls with handling package, magnaflow mufflers,dual exhaust, 3.55 rear axle
Joined
·
165 Posts
Alright, so hello! I'm Jacob.
I'm new here, like BRAND new my guy.

Had a guy recently swap a 2000 Mustang gt 4.6 into my 1999 crown vic. The base model. And I've got some issues.

It sounds and feels like a misfire.
I've got stumbling, loss of power, and that kind of off-beat sounding exhaust sound.

I've replaced spark plugs, coil packs, injectors, and today I replaced the o2 sensors. I thought maybe a catalytic converter was clogged, but I can blow air through it with my mouth and it comes out the other side.

I cannot, for the life of me, figure out what is the problem.
No check engine light... No codes...
Are you using the pcm from the mustang or the crown vic?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Also I need to add that I can disconnect the wires to the injectors on the driver side and no change to the idle. If I do that on the passenger side, you notice a huge difference to the idle.
 

·
Super Moderator
Joined
·
1,294 Posts
If disconnecting injectors does nothing, you found the dead cylinders. Now you’ll have to figure out what the issue is. I’d rule out spark as an issue so that would leave fuel and air.

Did you do a compression check? I would start there.


Sent from my iPhone using Tapatalk
 
1 - 8 of 8 Posts
Top