Ford Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2003 Navigator that stalls when I try to pass. As soon as it goes into overdrive it stalls and gets a p0320 fault. It dosen't matter if I'm going 25 or 70 it happens every time. It runs and drives great as long as I dont accelerate too quickly. No rough idle. When it happens all I have to do is put it in neutral turn off the key ,restart it , put it back it drive and go. Any ideas
 

·
Super Moderator
Joined
·
1,025 Posts
It seems there is a tsb stating that the alternator harness is to blame. This person had the same problem as you and thats what it turned out to be. The link should help you look for the issue.




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
38 Posts
85ltdcrownvic is right on the money.The pictures below show the area of concern that youll either need to fix by repairing the wires in question or by replacing the harness in full.The wires rub on an AC pipe causing the insulation to wear through until the,now bare,alternator wires start shorting against the pipe.The following is the part number for the harness. #2L1Z-14305-AB

DSC00849.jpg DSC00846.jpg DSC00844.jpg
 

·
Super Moderator
Joined
·
1,025 Posts
85ltdcrownvic is right on the money.The pictures below show the area of concern that youll either need to fix by repairing the wires in question or by replacing the harness in full.The wires rub on an AC pipe causing the insulation to wear through until the,now bare,alternator wires start shorting against the pipe.The following is the part number for the harness. #2L1Z-14305-AB

View attachment 51604 View attachment 51605 View attachment 51606
Hey man its good to see you over here. Im over on modded too, have been since 2011 but its so slow now. Its good to have a heavy hitter like yourself over here.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
38 Posts
Hey man its good to see you over here. Im over on modded too, have been since 2011 but its so slow now. Its good to have a heavy hitter like yourself over here.


Sent from my iPhone using Tapatalk
Thanks for the acknowledgement and I agree,it is slow at MM.Good to be & see you here too.I enjoy helping others when I can,so it'll do me some good to try some more active sites.Good seeing you.
 

·
Super Moderator
Joined
·
1,025 Posts
My username is 07gts197 over there by the way. And welcome to the forum!


Sent from my iPhone using Tapatalk
 
1 - 7 of 7 Posts
Top