Ford Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Alright so I’ve got a 2004 Expedition 5.4L Eddie Bauer. For the past three years itll stall out during the summer (so I’m pretty sure it’s related to the heat) when coming to a stop or stopped. Last summer it was given to me for my 16th birthday and to fix the problem we were told to replace the fuel pump because it was collapsing and that seemed to fix it. But this summer it started breaking down again so we took it to a shop they said it was the fuel pump again so this time we replaced it with an OEM part and that definitely didn’t fix it because after a $900 job it broke down the next day 🙃. The specifics on when exactly it breaks down is this: When coming to a stop it’ll just cut power and all my lights will come on. Typically I can just take the key out and put it back in and it’ll start right back up but it’ll break down soon after so I have to wait a few minutes so I can drive it a further distance. But the other weird thing is it’ll cut my power when I’m on the highway but it won’t kill it completely. No lights come on but for 5-10 seconds I just idle and then I can accelerate just fine after that. Idk what it is, my engine has been rebuilt, new fuel pump, fuel filter, fuel line. I’d y’all have any ideas or have had a similar experience please let me know. I’m trying to sell it but I’d like to either fix it or give someone a solid reason as to what wrong with it other than guesses.
 
1 - 1 of 1 Posts
Top