Ford Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2005 Mercury Grand Marquis that I changed the starter on. I have to jump it to get it to start. The battery doesn’t seem to charge. I’ve tested the battery and it tested as good. Any suggestions?
 

·
Super Moderator
Joined
·
21,039 Posts
What voltage in battery ? Have you load tested the battery for weak / dud cells ? have you checked the alternator charging rate ?
 

·
Super Moderator
Joined
·
1,479 Posts
In addition to following Logan's advice, check the simple things, especially neglected battery cables. Disconnect the cables, then clean the terminals and battery posts with a battery cleaning tool. This is also a good time to clean any corrosion in and around the battery. Baking soda works. Finish up by spraying the terminals with corrosion protectant.
 

·
Registered
Joined
·
2 Posts
In addition to following Logan's advice, check the simple things, especially neglected battery cables. Disconnect the cables, then clean the terminals and battery posts with a battery cleaning tool. This is also a good time to clean any corrosion in and around the battery. Baking soda works. Finish up by spraying the terminals with corrosion protectant.
I second this. I had to replace my battery cables from the battery down to the starter. My starter gear would pop out and stay out while I was driving because the wires were corroded and not giving the starter the proper voltage

Sent from my SM-G965U using Tapatalk
 
1 - 4 of 4 Posts
Top