Ford Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My 2014 Edge has experienced a yellow "caution" light twice. For no apparent reason the gas pedal is not engaged. I coast over to stop. The engine still running. I turn off the ignition, sit for 5 minutes then restart the car. The caution light has disappeared and the car runs perfectly. Several days later it happened again. This was several months ago. I"ve continues to drive the car....avoiding freeways in anticipating it happens again.

I've had it at the Ford dealer twice. They say it can't be fixed without the code. I now have a blue driver to read the code when it happens again......After several months, it hasn't happened again.

The car has run perfectly for 6 years. I only have 35,000 miles. I really LIKE the car! Any suggestions, other than trading it in.....and passing along the problem to the new owner?
 

·
Super Moderator
Joined
·
9,616 Posts
It was a caution light, if it was solid and not flashing, it's not likely to shut you down. You have a means of reading the code now, you have part of the battle won. Since it was very sporadic and rare, it could very well be a misfire or something similar brough on by gas with a high moisture content, excessive idling or a number of other things that a car can tell you about now. If you enjoy the car, keep the car, and if it happens again, you can immediately have the code to present to your mechanic and he/she can help you interpret the code.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks CatSkinner.
Your answer makes sense. I am prepared to get the code. I like the car. 6 years old but only h 35K miles. Thanks, Glenda
 
1 - 3 of 3 Posts
Top