Ford Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello, I have a 2018 Mustang Ecoboost with the Sync 3 touchscreen radio and I've noticed that the screen will not turn on when it is cold outside. After the car has been running for 30 minutes to about an hour with the heat running inside the radio and screen will then turn on. I've noticed that the usb ports will not have any power at all but I can still control the temperature with the dials even though I cant see what temp its set to since the screen will not be on. I tried doing the reset where you hold the power button and next track button at the same time and that has no effect on the radio at all. It will only turn on after the car is completely warm inside. Has anyone had a similar issue or have any ideas what this could be?
 

·
Super Moderator
Joined
·
21,039 Posts
Should still be covered by warranty , contact dealer . Another thought , sometimes when battery in low condition in some cars it will cut off non essential items , especially if others needed are being used . Then when driven for a while the alternator has boosted the battery enough and they will function normally again . Could check your battery voltage first thing in morning before starting .
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
UPDATE: Checked my battery voltage after the car was sitting for a few hours and it was down to 11.3V so just to be safe I went out and bought a new battery and installed it. This did not fix my problem so the next step I'm taking it to get it to a dealer to have them look at it and fix it. I will update again about what the issue was once its fixed.
 

·
Super Moderator
Joined
·
21,039 Posts
11.3V is a faulty battery or at least needing charged . Might be worth doing the same check with your new battery as you could have a parasitic drain .
 

·
Registered
Joined
·
1 Posts
Hello, I have a 2018 Mustang Ecoboost with the Sync 3 touchscreen radio and I've noticed that the screen will not turn on when it is cold outside. After the car has been running for 30 minutes to about an hour with the heat running inside the radio and screen will then turn on. I've noticed that the usb ports will not have any power at all but I can still control the temperature with the dials even though I cant see what temp its set to since the screen will not be on. I tried doing the reset where you hold the power button and next track button at the same time and that has no effect on the radio at all. It will only turn on after the car is completely warm inside. Has anyone had a similar issue or have any ideas what this could be?
Hello, thanks for sharing, I have the same issue with my GT mustang 2018 but if it doesn’t work work from the beginning the it won’t work that day at all even after running hours
 

·
Super Moderator
Joined
·
21,039 Posts
Could check with your dealership if it is a known fault and possibly there may be software update that cures this fault .
 

·
Registered
Joined
·
1 Posts
Hello, I have a 2018 Mustang Ecoboost with the Sync 3 touchscreen radio and I've noticed that the screen will not turn on when it is cold outside. After the car has been running for 30 minutes to about an hour with the heat running inside the radio and screen will then turn on. I've noticed that the usb ports will not have any power at all but I can still control the temperature with the dials even though I cant see what temp its set to since the screen will not be on. I tried doing the reset where you hold the power button and next track button at the same time and that has no effect on the radio at all. It will only turn on after the car is completely warm inside. Has anyone had a similar issue or have any ideas what this could be?

Hello I have same problem on my 2018 Mustang Ecoboost please let know if dealer fix the problem & how much they charge you
thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Hello I have same problem on my 2018 Mustang Ecoboost please let know if dealer fix the problem & how much they charge you
thanks
The dealer did fix the problem I forgot exactly what the issue was and i lost the repair order. it was something about a 8 pin connector that went bad. if your car is under 36,000 miles you will still be under the bumper to bumper warranty and it will be no charge to you. I cant tell how much it would be since mine was warranted.
 
1 - 8 of 8 Posts
Top