Ford Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
hi guys i have a 56 tbird with a 3 speed manual plus over drive,,it was working ok then all of a sudden i heard a few stange noises a it dissengauged it self and no longer works, does any one know about these boxes ,i should also mention i live in melbourne australia ...............cheers glenn
 

·
ynot-yblock
Joined
·
16 Posts
Muggle
those trannies are usually hard to break, but the overdrive units have other issues. It sounds as if the transmission has lost some shift forks, but the overdrive can make life miserabel. as well. Can you tell which component is giving you grief?
 

·
Registered
Joined
·
13 Posts
Step one: Accurately define the problem
With car in the air or drive shaft removed, depress clutch and rotate output yoke. Is noise and feel in each gear? Reverse?

Tom Compton
Austin, Texas

'56 Victoria, 325 CID Y Block, T5 Overdrive giving the ricers and bow ties fits!

Sooiiee Pig! Go Hogs!
 

·
Registered
Joined
·
1 Posts
from what you describe, i would bet money that the o.d. was ran with no oil in it. This will cause the planetary and sun gears to weld themselves together. The end result is a nasty noise and a loss of overdrive and reverse
gear.

Remove the fill plug or governor on the o.d. and use a tie wrap or somethig similar to check oil level.

I have seen this happen many times. you have to check/add gear oil quite often to be safe.

Good luck, hope this info is helpful.
 
1 - 4 of 4 Posts
Top