Ford Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have 75hp injectors, Diablo Predator programmer set on 100hp, 4" exhaust, banks upgraqded turbo and intercooler, also a airade intake. First thing in the morning it runs fairly strong but mid day or by the time it is warmed up it looses alot of power. It sounds like it is haulin butt but it really is not. I NEED HELP!!!! A power stroke with just an 80hp chip out runs me and a stock 2004 duramax also out runs me!!!! Any suggestions????
 

·
Registered
Joined
·
917 Posts
Ryan 7.3 PSD said:
I have 75hp injectors, Diablo Predator programmer set on 100hp, 4" exhaust, banks upgraqded turbo and intercooler, also a airade intake. First thing in the morning it runs fairly strong but mid day or by the time it is warmed up it looses alot of power. It sounds like it is haulin butt but it really is not. I NEED HELP!!!! A power stroke with just an 80hp chip out runs me and a stock 2004 duramax also out runs me!!!! Any suggestions????
I think it might be leaning out when warm , have the mixtures checked when hot.
 

·
Registered
Joined
·
917 Posts
Ryan 7.3 PSD said:
also the truck poors out alot of black smoke when i am on the gas. Could it still be running lean???
back smoke is to much fuel , it needs a gas tester in the exhaust pipe .
 

·
Hi-Tech *******
Joined
·
1,486 Posts
If I remember right, there is a TSB about the valve cover gasket connectors coming loose on the inside of the valve cover causing missfire, smoke, loss of power, etc.

You can do this yourself........................
Remove the passenger side valve cover and carefully inspect the wiring connector on the inside of the gasket. If it is loose, then go to the Ford Dealer and ask for the special clips that make them fit better.

I said to do the passenger side first because it is easier to get off, but you will need to check both.
 

·
Pursuit Reincarnation Dog
Joined
·
7,777 Posts
Sounds more to me like you may have a fuel problem - like quality of the fuel. If the cetane rating is too low you'll be burning the fuel and the engine will be working hard but it won't be making power. Makes sesne because low cetane fuels work okay in cold engines. Go to a reputable big chain gas station and get a good load of fuel - maybe bang in a cetane booster to see if it makes a difference.
 

·
Registered
Joined
·
107 Posts
hey
desiel easy
check the colour of your turbo and manifold.
now if you manifold and turbo are nice and rusty looking move on but.
if the manifolds are turning a bluey/gray colour and your turbo is still rusty you have a boost leak (not getting full boost) so throws heaps of fuel but not enough air to burn it all lots of smoke.
if your turbo is blue but the manifolds are rusty or turing blue as well have your wastegate checked and inspect the turbo hot wheel for damage and the cold wheel to.
check the programe in the computer to see its not over fueling badly.
check your air cleaner for being blocked up and your intake tubes for being sucked in etc.
this is 9 times out of 10 the problem with low power lots of smoke on desiels.
drift
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
thanks for the advice skid as soon as i get my truck back ill check that out but its at a desiel shop in orlando FL right now because of boost problems. because i am only boosting 18 pounds now when i use to boost 27 so you may be right
 

·
Registered
Joined
·
107 Posts
hey
yep there's ya problem sounds like a tubo has munched its self.
drift
 

·
Registered
Joined
·
11 Posts
Discussion Starter #12
skid, i was thinking my turbo is covered in oil. i can clean it and drive it for a day and there is oil on it again What do you think???
 

·
Registered
Joined
·
107 Posts
hey
ya oil feed/return line in leaking ether from the gasket cracked/split pipe wash it off go for a 5min drive then have a look this should be amble to see where its coming from.
if your really unlucky you might have blown an oil seal out of the turbo and be pumping oil out from the turbo doesent happen very often.
did they fix the low power high smoke problem?
skid
 

·
Registered
Joined
·
11 Posts
Discussion Starter #14
well i uess its fixed... it runs alot better since i got it back for the diesel tech. my waste gate wasnt adjusted so it was staying partly open and i had a blown O ring in the turbo, they also said that the 2 pipes running to the turbo from the engine had extreme exhaust leaks to wear it at in to the pipe and then one of my exhaust manifolds were leaking. Soo now i am boosting 28 - 30 pounds of boost and it seems to be running alot better. needless to say the turbo sounds great now its nice and clean sounding. But i still have an unbelievable amount of smoke. Id like to do some thing to burn teh rest of that fuel. I was thinking water to methanol
 

·
Registered
Joined
·
107 Posts
hey
the only way to burn that extra fuel is to put extra air in.
whats your piro temp like? whats your intake temp like.
id try a water spray on the aftercooler to drop intake temps this will help burn a little more fuel.
drift
 
1 - 15 of 15 Posts
Top