Ford Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Okay so for a good while now my truck has been having a problem with acceleration. If I go to accelerate quickly from a stop the entire truck will shake very violently while going practically no where and will not stop shaking until I let my foot off of the gas and then very slowly ease back onto it. Another thing that I believe is related to the same issue is that let's say I'm at 20mph. If I go to accelerate from 20 to 50, it will accelerate at the same speed whether I floor it or slowly ease onto the gas. I don't know too much about vehicles. My dad says that it probably has something to do with the amount of fuel that is being let into the engine but he isn't sure. Any help is appreciated. Thank you all so much.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Check the vacuum at idle and raise the RPM to 2000 and see what the reading does. It should drop and raise back up almost the same as at idle.
I dont have an rpm gauge but from listening to it, it sounds like it goes back to idle just fine. But for some reason when I start the truck and it idles, it spits and sputters but the moment I put it into drive and start driving, it won't spit and sputter anymore until I turn it off
 

·
Super Moderator
Joined
·
18,968 Posts
With the further info about spits and sputters I would check for vacuum leaks . SOME trans had a vacuum modulator on the side of the box which could fail or the vac hose could leak / come off . Might / might not apply to your vehicle. With " the entire truck will shake very violently " I would be checking the engine mounts and driveshaft , plus centre mount . Another thing you could check would be the ignition timing .
 

·
Super Moderator
Joined
·
1,055 Posts
Thmdo, your trouble descriptions are little confusing, if not contradictory. Are you saying the problem is intermittent?
 

·
Registered
Joined
·
2 Posts
Okay so for a good while now my truck has been having a problem with acceleration. If I go to accelerate quickly from a stop the entire truck will shake very violently while going practically no where and will not stop shaking until I let my foot off of the gas and then very slowly ease back onto it. Another thing that I believe is related to the same issue is that let's say I'm at 20mph. If I go to accelerate from 20 to 50, it will accelerate at the same speed whether I floor it or slowly ease onto the gas. I don't know too much about vehicles. My dad says that it probably has something to do with the amount of fuel that is being let into the engine but he isn't sure. Any help is appreciated. Thank you all so much.
Might even be a torque converter issue.
 
1 - 12 of 12 Posts
About this Discussion
11 Replies
5 Participants
chipmanii
Ford Forums
Ford Forum is a community to discuss all things Ford. Check out our discussions on the Ford Escape, Mustang, Edge, F-150, Raptor, Explorer, Focus, Fusion, Fiesta and more!
Full Forum Listing
Top