Ford Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 95 with an automatic, which about 3 yrs ago was supposely rebuilt for $900.00 have receipt. After about a month the O/D light started flashing then would go out sometimes or stay on for days. The O/D light would also come on if it rained.
Now fast forward to now just had a whole new rebuilt trans put in got a core trans and had all new parts installed. O/D light started coming back on. I can reset it by resetting computer but every now and then comes back on.
Now I have heard this could be a bad GEM MODULAR. and I have also heard that Ford had to update the ECM's on 95's to fix this problem. Now here's two other things which make me feel its the GEM. When the truck gets to a half tank of gas the check gauge light comes on and the gas hand shows empty. You have to turn engine off and back on to get guage to work. Also the rear left window stops rolling up and down for several days then all of a sudden it starts working.
My understanding is the GEM MODULAR is needed for all these problems I have noticed. I understand that if I don't fix problem with the O/D light flashing trans could burn up again. All and any help with this is much appreciated.................. :help:
 

·
Registered
Joined
·
8 Posts
We have a similar problem...our only thing is the O/D Light coming on. When it comes on on our 95 Explorer there is a "thumP" that occurs when braking. Other than that no other symptoms. We had our transmission rebuilt...and took it in 10x after, exhausted at the reoccuring problem. This last time we were given a Service bulletin showing that the PCM Module needs to be reprogramed...and that this would correct the problem. We took it to Ford and they told us that due to the computer system in our 95 Explorer being obsolete, there is nothing they can do. I'm in the works of trying to get help from Ford Motor Company....We just can't understand how Ford can't service their own vehicles.
 

·
Registered
Joined
·
71 Posts
On they 95's the PCM Module needs updated. Mine was doing the same thing last week. Took it to Ford, they tested the trans. and saw no problems with the trans. After checking the trans. they informed me the PCM Module needed updated per the Ford Service Bulletin. I would recommend finding another Ford Dealer, sounds to me the one you went to is just trying to get you to buy a new transmission.
 
1 - 4 of 4 Posts
Top