Ford Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
ok guys, first post here...

have been driving my 03 BA Fairmont for about 2 months after buying from a private seller, great car absolutly no troubles with it... however... recently as in about a week ago, the AIRBAG light, continues to stay on after ignition and continues flashing, i rang the ford tech guys and they asked me to take it in, however being almost 300KMs from them is a bit inconvinent.. so my question is... what the hell is it doing on? i was on a smooth road, no bumps or anything like that..

any help would be great, saving me to drive the 300kms, plus the guys at the local garage, dont really know what an engine is anyhows..

anyway to get ot off? or do i have to take it in? thanks guys..
 

·
fordmech
Joined
·
315 Posts
Hi mate
Read what code it is by counting the number of flashes after you turn the ignition on. BAs had a problem with the Side airbag connector which is located under the plastic trim at the base of the seat. If the code is either 22 or 23, move both front seats back and forth to different positions and cycle the key off/on and it should go away. If it doesn't then the connector (yellow) may need cleaning or crimping to improve contact. Please, do this last thing after disconnecting the battery AND waiting a couple of minutes. Under no circumstances touch the female part of the connector. This goes to your side air bag and it deploys really easy. Let me know if you have any dramas. cheers
marc
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
hey matey, thanks for the advice, although i moved my seats around, and the problem seemed to go away... so that puzzles me a bit haha... it will most likely come back, but will deal with it then...
 

·
fordmech
Joined
·
315 Posts
That's right. The problem is caused by 2 things: the female part of the connector is a bit too big for the male pins and the routing of the wiring causes it to pull on said connector when you move your seat to different positions and that will give you a shitty contact, which means a higher resistance, which means your airbag light on. The modules are very sensitive and you only need 0.5 to 1.0 ohm in either direction to give you a light on.
Ford released a TSB to correct this problem but it seems to me that your car is out of warranty and you'll have to pay for it (expensive if you have to replace one of the airbags), so if you have any kind of warranty that will cover this repair, bite the bullet and take the trip to your dealer. cheers
marc
 
1 - 4 of 4 Posts
Top