Ford Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I bought a 73 Galaxy 500 2 door hardtop with a 400, Cruise-A-Matic, 73,000 original miles. It is a number 3 in condition.
Needs a tune up but needs to be driven even worse. It has been sitting a few years. But it does start & run.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Not yet, I'll have to take some & will post. The car is at my buddies about 160 miles away. I plan to go do some work on it this weekend to get it ready for a 160 mile run home.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Still haven't got pictures. Forgot my camera on my last trip. But changed out the master cylinder, aired the tires up, took it to the car wash & got it cleaned up a little. Took it for a drive. It ran out great, way better than I expected. It still has the factory bottom radiator hose & heater hoses. The only mechanical things to do is convert A/C to R134A, rebuild the carb, it is leaking gas at the accelerator pump. Install new fan belts, put on the new bottom radiator hose in the truck just because.
Then need a seat reupholstered & new head liner, misc small stuff. It has new radial tires in 225/75/15 tires. I will have dual exhaust put on, & might try & find a set of mag wheels.
So I'm pretty pleased with with my buy. I bought it right. My buddy owns several collectable cars, this being one of the least as a collector car. He pretty much gave it to me. I have bought several cars from him over the years. In fact two of our vehicles our F150 & Crown Vic came through him.
I'll get pictures up when I get them.
 
1 - 8 of 8 Posts
About this Discussion
7 Replies
4 Participants
CatSkinner
Ford Forums
Ford Forum is a community to discuss all things Ford. Check out our discussions on the Ford Escape, Mustang, Edge, F-150, Raptor, Explorer, Focus, Fusion, Fiesta and more!
Full Forum Listing
Top