Ford Forums banner

1 - 4 of 4 Posts

·
au2 forte
Joined
·
139 Posts
Discussion Starter #1
Hi,

I've got a 6 cycl AU2 forte sedan (auto) which I bought new and have had for about 7 months now (no mods).

One week or so after I bought the car, I had a ford alarm installed, which was done at the dealership. Soon after, my tacho on the dash stopped working. The other guages (speedo, temp, fuel etc) worked fine and the car engine itself was ok. I took it bbk to the dealer and they reloaded the software in the cluster (i think??). But that didn't work and in the end they declared the cluster as faulty and replaced it with a new one (free of charge as its under warranty).

About a month ago the SPEEDO dial went totally DEAD permanently! And later on the the fuel gauge started randomly fluctuating while driving (like a VU meter, but only sometimes). I took it back to the dealer again and they said "yep faulty cluster" and had it replaced with a new one (again free of charge)...

So far this cluster is working (touch wood) but I have a couple of questions:

(1) Does this happen to anyone else?
(2) Does anyone have any suggestions as to what is causing the
cluster to fail, or is just a coincidence...The ford mechanic seems to think that the chances of 2 new clusters failing on a new car is just extraordinary.

Cheers,
 

·
Chromed Member
Joined
·
1,810 Posts
:D

Check for moisture in the drivers footwell kickpanel.. water leaks down there sometimes when it really rains hard, once wet the plugs never dry up and can do stupid things to anything electronic. You have to disconect the battery, unscrew scuffplate, roll back carpet and disconnect plugs to check for moisture. blow out with air if available and spray with contact cleaner. dry out with hair dryer or sunlight.

Not saying it is the problem but could be:D ive found water in these plugs which caused fuel gauge problems and drivers airbag warning to come on;) ;)
 

·
Two SC 61's = trouble
Joined
·
6,360 Posts
Another: could be faulty battery and alternator is overcharging,loose battery connections too.
 
1 - 4 of 4 Posts
Top