Ford Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
230 Posts
Discussion Starter #1
Lifted the dip stick out of the hole just because the bonnet was open on the weekend.
Level is sitting on the 'Add' mark, never noticed any previous dip in oil level up to the present.
Just over 20,000km on the clock and yes I have checked the level since the 15,000km service.

I don't mind adding oil on occassion, just thought the I6 was not known as a user of oil at such low km.

Anyone with a few more kms up that can comment.
 

·
Two SC 61's = trouble
Joined
·
6,360 Posts
Level gound and was engine hot or run latley can do this, not enough time for oil to settle back to sump..?? I check cold...
 

·
Registered
Joined
·
230 Posts
Discussion Starter #3
Level ground and not run for a day.
So I guess that means cold, but as it was parked hot the oil should all find the sump.

Checking, checking, checking.
 

·
Registered
Joined
·
1,944 Posts
supermono,

What viscosity oil are you using?
 

·
Registered
Joined
·
230 Posts
Discussion Starter #5
In the original case, whatever the dealer sticks into it during a service.
So you assume (dangerous to do that I know) that it is a suitable product meeting Ford's specs.

As a top up, I added a variation of Mobil 1 as I keep it on hand for my racing bike.
Basically a multigrade synthetic, at $10+ per litre.
I'll be doing about 500km by next Monday so I'll see what happens over that time.
 

·
Registered
Joined
·
230 Posts
Discussion Starter #6
I've put nearly 1000km on this thing since I had to top up the oil.
No movement on the stick so for the moment no problem except for the location of the 'missing' oil.

No puddles, no smoke, no idea.

If it starts using oil again, I'll let you know.
 

·
Just give me an excuse...
Joined
·
3,949 Posts
I have done 24000km and no oil usage. I use 10w30 Shell oil. Hope all is ok with yours.
 
1 - 7 of 7 Posts
Top