Ford Forums banner

1 - 10 of 10 Posts

·
wasting money on cars
Joined
·
611 Posts
Discussion Starter #1
my xr8 ute has started to become very creaky in the rear suspension. anyone else in the same boat 1 month old??
 

·
X-DM!!
Joined
·
1,114 Posts
dicast, mine does the same sometimes. I had the kingspring suspension fitted front and rear. It sounds like the noise is coming from the rear bushes though.
 

·
Registered
Joined
·
2,784 Posts
greetings Diecast & welcome
i had the same problem with mine check the rear leaf springs they have these silly little disc things between the leave & when you jack up the car or hit a large bump & the car goes up in the air they move out of position

try a little grease between the leave's that should fix it or spray them with TAC 2 is a spray on grease made by CRC

regards
rod
 

·
wasting money on cars
Joined
·
611 Posts
Discussion Starter #4 (Edited)
this sounds funny but it is really noisy when i first drive the car.but after a while it goes away. but will give that a try thanks rod!
 

·
X-DM!!
Joined
·
1,114 Posts
I had another problem similiar with my au xr8 ute as well. Ford sprayed both rear springs with crc and tightened up u bolts ect ect. Going home about 2ks down the road the noise comes back, turned out to be one of the style side cross members rubbing on the chassis. They took the style side off and shimmed it up a bit to give it a bit more clearance.
 

·
Pursuit Reincarnation Dog
Joined
·
7,777 Posts
Mine is SHOCKING and the creaking is driving me balmy. It's worse just after wet weather or washing the car. It creaks when I take off from rest or hit certain bumps.
 

·
Was XLS, now XR8 UTE!!
Joined
·
313 Posts
My rear leaf springs are rubbing on my chassis! on both sides, but the drivers side is worse, starting to grind into metal...

also have a banging noise when hitting bumps and the like.. looked at the tub liner, could do with a few self tappers on the floor, or could it be the hard top?

ummm

Teza
 

·
Pursuit Reincarnation Dog
Joined
·
7,777 Posts
Teza_XR8Ute said:
My rear leaf springs are rubbing on my chassis! on both sides, but the drivers side is worse, starting to grind into metal...

also have a banging noise when hitting bumps and the like.. looked at the tub liner, could do with a few self tappers on the floor, or could it be the hard top?

ummm

Teza
Teza,

Mine's exactly the same. I posted pics of the chassis rail damage a while back. I asked FPV/Ford to put in writing that the car meets all safety and roadworthiness standards with this apparent defect. No reply as yet despite promises.

Pete.
 

·
Registered
Joined
·
336 Posts
Yeah count me in for the grinding and bumping from under the back there somewhere...

Seems each time I carry any sort of load it moans and grinds for the next couple of days... I have looked and pushed and prodded and can't find where it is comming from. Will get dealer to have a look though.

I am not too worried though, my AU one tonne did the same...
 
1 - 10 of 10 Posts
Top