Ford Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all Ford drivers,

I have had a automatic transmission problem for a few weeks now that seems to be getting worse, but I cannot work out if it the transmission that's playing up or the computer. Particularly when it warms up it kicks and changes gears up and down without control. Mostly 1st to 2nd and 2nd to 1st gear. Occasionally it is also happening between 2nd and 3rd and 3rd and 4th but less often. Sometime I switch it into the gear shift mode and I can change gears up and down and sometimes even in this "perf" mode it changes gears on its own with pretty bad kicks. More recently in the last few days, I couldn't start it as if it is stuck in Drive and it won't start. I gently jerk the gear level in Park and Neutral and eventually start it. Once it took me 20 minutes. Starter motor just starts catch on and it cuts out.

There are times that I can drive it for half an hour without any kicks in gear changes or just a couple and other times I have a sense the transmission will break apart and fall from underneath the car.

It has done 405,000km. I have changed the transmission oil and differential oil about 6 or more months ago.

I am wondering if anyone can tell me this is the transmission itself or the computer. Where could I take it for a good but reasonably priced diagnostic?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thanks for that. I will check and report back.
Hi I am back. I had two fault codes, P1213 (Injector Circuit 1 short to positive (Audi, WV) which doesn't make sense) and U1900 (CAN communication fault), neither seemingly related to transmission. I took it to my local Ford dealer on Tuesday and they couldn't fault it but said it needed LPG converter service. I haven't driven it much since Tuesday, as I now work from home but I had no troubles with transmission. I will report back again if anything happens. I will see what other fault codes may come up.
 

·
Super Moderator
Joined
·
3,706 Posts
What code reader were you using? The U1900 (CAN communication fault) code will often come up if your using an ELM327 or similar with a bluetooth or wifi connection and it loses coms between the ELM and phone or whatever device you are using; it's why (together with their better speed) I prefer to use the USB ones with a Ford switch (e.g. USB ELM327 Modified Elmconfig MS-CAN HS-CAN Forscan Ford Mazda OBD2 Chip Tool AU | eBay) and Forscan ( Download FORScan) with a windows PC. On a BA Ford the P1213 indicates the LPG prime solenoid is not working. Check the wiring to the solenoid. It's also worth downloading the Ford Factory workshop manual from https://www.motorcraftservice.com so you have the correct interpretation of the fault codes. For a $21.95 subscription you will have more than enough time to download all you need. Just note that if section numbers are missing from the sequence it means that this part of the manual is unchanged from the previous model(s) and you have to download those sections from those prior models as well.
 
1 - 5 of 5 Posts
Top