Ford Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I own a 2016 Ford Transit 350HD Ext 3.2L Diesel. My blower went out last November and I just got around to it. I replaced every fuse and relay for the blower motor and even replaced the blower motors itself and the resistor. I hooked it all up and it blows fine on all four speeds, AC is still cold, heat is still hot. My problem is that the air will not come through the vents... it does, but very very very softly, like someone is just trying to blow with their mouth through the vents. One of the issues I think it might be it is that the blower (that I bought from ford, by part number, and even had it VIN verified by the dealership I bought it from) won’t let me tighten the screws all the way. If I do tighten the screws all the way the circular blower blade rubs against the plastic to a point where it won’t move because it’s stuck. I have it tightened just tight enough to where it’s good in the slot but not hitting anything, but it will not blow air though the vents. Am I missing something? Is there a certain way the blower is suppose to sit in it’s spot? My next move is to take a plumbing snake and feed it through my vents to see if any wasps or rats got comfortable in the absence of the blower. I hope someone can help me haha.
 

·
Super Moderator
Joined
·
8,596 Posts
I was hoping to find an install video, but no luck. First, if you have the original, check it carefully against the new one for dimensions, if they're all the same, you may not be installing it evenly.
 

·
Super Moderator
Joined
·
20,942 Posts
Just to add to above , not sure if that vehicle has a cabin filter .If it has , a blocked filter can restrict air flow in general
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I was hoping to find an install video, but no luck. First, if you have the original, check it carefully against the new one for dimensions, if they're all the same, you may not be installing it evenly.
I got it to seal in properly and it’s still not blowing through the vents at all. Not even on high speed. Someone suggested maybe it’s the blender doors? Any advice on that?
 

·
Super Moderator
Joined
·
8,596 Posts
It's a damper that directs the air to heat or cool Found videos for pulling it out of an E series van... but not for a Transit.
 
1 - 7 of 7 Posts
Top