Ford Forums banner

1 - 9 of 9 Posts

·
WHAT THE?
Joined
·
925 Posts
Discussion Starter #1
Just lately I've noticed that my car seems down on power. I'm pretty sure it used to pull a lot harder than what it does now. One thing I've noticed is that my mate's EF Fairmont seems to suck in a lot more air through the intake than my car, and considering that an engine is basically a big air pump and that my engine is worked and his is stock - it's a bit concerning. All he's done is a 2.5" exhaust with a single muffler from the cat back and put on a pod filter. The reason I noticed his car 'sucks' more :) is because we were putting on the pod filter and I put my hand near the intake pipe when he pumped the throttle a bit.....and my hand almost got sucked in! I couldn't believe the force! Now if I do the same thing in my car, you can easily pull your hand away...its like pissy little vaccume cleaner suction!

Also, when I'm driving around, it's hard to describe, but the engine feels kind of sloppy....like it revs a lot but doesn't go anywhere. Where as if I drive his car or even mum and dad's stock EL, you get instant throttle response and everything feels tight.

The car's getting on a bit, it's done 283,000kms so I'm wondering if maybe the actual rings are worn or something and it's losing compression and power because of that. It also chews through a lot of oil although it doesn't blow smoke (only on startup and it's black). I haven't had a close enough look to see if it's just leaking from somewhere. Anyone got any thoughts on what could be going on? Am I lookin at a re-build or maybe engine swap? Cheers.
 

·
Ford Appreciation Society
Joined
·
3,666 Posts
Sounds like another AU engine upgrade in the pipeline!

Have you taken it for a dyno run recently to see what it is actually putting out at the wheels??
 

·
Often has bolts left over
Joined
·
848 Posts
I'd make sure its not something simple like a rooted throttle cable before you start thinking about engine rebuilds.. you've probably already checked though. Do you have an EF/L BBM?
 

·
Banned
Joined
·
3,104 Posts
Blocked cat?
Fuel pressures up to scratch?
 

·
Registered
Joined
·
30 Posts
i'd check the cat first off because when my cat was plugged i had the same thing. before i found out it was the cat i had checked all the vacuum hoses and my carb and all that, so i thought what the heck and i went and cut off the cat, that fixed a few problems.
 

·
LET EM' RIPPP
Joined
·
1,819 Posts
Doug,

Just a few things first.

The EF/L BBM makes a Big torque improvement down low, and as you know, in some cases, bigger aftermarket cams can make your car loose out down low… probably the difference your seeing.
Also, your head work involved the removal of the chamber swirl. This swirl is used to improve torque, but obviously sacrifices top end power as a result. By removing it, the compression of your engine was also reduced as you didn't use a thinner gasket to help bump it back up.

If I were you I'd be checking things like ignition timing, and as mentioned above, comp testes etc.

Worst case, put it on the dyno again... it could just be that you are used to the thing, or the hot days my be slowing it down.

Oh, and the black smoke on start up is excess fuel. Oil burns white.

Simon
 

·
E-Series Cameraman
Joined
·
1,388 Posts
Mines been doing this as well ever since I put the EF head and stage 2 cam in. Even with the manual its a slug, like plenty of revs but no go. Steven suggested that because of the EF head the compression is a bit lower now, but even then I reckon most cars will still beat me in a drag. I can't even smoke up the tyres :(

Or it could also be the fact that I'm used to driving nothing but AUs and BAs all day everyday...

Alex
 

·
400 kg ego
Joined
·
6,188 Posts
GhiaEB had problems with sluggish running with an EF head - obviously it is a mod that requires a bit of extra effort to run properly.

Doug, has the car only done this since the Unichip?
 
1 - 9 of 9 Posts
Top