Ford Forums banner

1 - 6 of 6 Posts

·
Falcon 2.. Ferrari 0 hehe
Joined
·
1,290 Posts
Discussion Starter #1
i went to drive my car just before, and on gas it drive goodf or 100 meters or so, but them, dont wanna rev more than 1200.... if i press 'go' more, it revs up a little, then dies, revs up and dies revs up and dies??????? switch to petrol, and drive a bit, then back to gas, goes good, then does it again????? the converter is gettignwater.. and its got 1/4 of a tank (thats wha the tank guage says but ive done about 200 kays on 15 bux of gas) could it be empty? or more serious?
 

·
Bourbon powered V8
Joined
·
4,751 Posts
Fill the gas tank (or at least put $5 worth in) and if it runs fine, you know you were empty (or close to it).

If that doesn't work and it runs fine on petrol, get the gas system checked by a pro.
 

·
Registered
Joined
·
162 Posts
I had TE cortina on LPG that did the same thing. Does it run fine when you initially start the car and then starts idling funny etc after the car has warmed up?

I found with my cortina that the converter would freeze up, with ice visible on the outside and very very cold to touch. Make sure you are running coolant and not distilled water and that it has some sort of anti-freeze in it.

That's all i can really suggest. Other than that, don't run it on LPG anymore?
 

·
Falcon 2.. Ferrari 0 hehe
Joined
·
1,290 Posts
Discussion Starter #5
the guage inside said 1/2 in the tank said 1/4, but nothing in it, i filled it up, and geez, gas does wonders! hahaha
 
1 - 6 of 6 Posts
Top