Ford Forums banner

1 - 5 of 5 Posts

·
Officially Bored with 347
Joined
·
3,584 Posts
Discussion Starter #1
Hey ummm i know this is for techy stuff but my car has vanished from "Owners Cars" section whats up with that????
Cheers
Brett
 
S

·
Guest
Joined
·
0 Posts
Brett, don't ask me ;) I dont mantian page now... Ask Kelli or Mike. how is your car going anyways?
 

·
Officially Bored with 347
Joined
·
3,584 Posts
Discussion Starter #3
Hey Hey happychap........
Everything is A OK, cars all fixed had to get it ripped apart cause of that oil press. prob & luckily no damage was apparent ( had a looksey myself) & whilst they were at it got a restrictor kit fitted. Been flat out lately with the new job ( copper mine 2wks on 1 off) so i now have invested in my own pooter finally.. Hows things going your end & did that ECU sort out all ya probs??
Cheers
Brett
 
S

·
Guest
Joined
·
0 Posts
Ya that ECU fixed the problem straight away.
she idles now (when I get the heads on going for a E303 cam. :) Speaking of jobs, I resigned from my job at the dealership, only two days to go!! CANT WAIT a free man... get my sanity back! Least your on 2 and off 1, in Alaska they are on for a month. Not even aloud grogg in the place imagine that for hell.

So what was the problem with the engine... was it the oil pump pressure valve thing or something else?
 

·
Officially Bored with 347
Joined
·
3,584 Posts
Discussion Starter #5
When i ripped the sump off i found 1 bolt sitting in the pan & the other had worked its way loose so that the oil pump was just swinging in the breeze..... Now the bolts have been drilled & tie/wired to prevent anything like this happ'n again Fancy that hey..... Ouch no beer huh thats gotta hurt luckily the camp where i am allows Alcohol & last week they got a band up for us not too shabby huh!!! Anyways my friend good to hear alls well on your end
Take it easy alrighty
 
1 - 5 of 5 Posts
Top