Ford Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My EB Fairmont has had this issue for almost a year now, where the climate control module seems to be stuck in a self check mode or something?

The display is backlit when I turn the key, but nothing else happens. No fans, no air con, nothing. I have no control over the module, none of the buttons do anything.

I have had it out in the past and checked all the soldering, and didn't notice any issues there. I've checked the continuity of all fuses and swapped all the relays around, nothing happened.

When this issue first started, it was intermittent, only happening every now and then. But it gradually got worse until now. It has come on by itself once in the last 8 or so months (for about 2mins and then stopped).

Any ideas?
 

·
Super Moderator
Joined
·
3,725 Posts
Try the self diagnostics that also resets the module. Press "floor" and "off" buttons down at the same time with engine on (well floor a microsecond before the off button) hold down for 5 seconds then release both buttons and after cycling through various tests it may come up with a fault code or if it detect no faults turn itself off and in the process reset the module.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Try the self diagnostics that also resets the module. Press "floor" and "off" buttons down at the same time with engine on (well floor a microsecond before the off button) hold down for 5 seconds then release both buttons and after cycling through various tests it may come up with a fault code or if it detect no faults turn itself off and in the process reset the module.
I've tried this quite a few times in the past (both with the engine on and off), tried it again just now, and nothing. I've attached what it looks like. Thank you though!
 

Attachments

·
Super Moderator
Joined
·
3,725 Posts
Unplug the CC fuse for one minute, plug it back in then try again. If that does not work try removing and carefully dismantling the panel as the membrane for the switches may be damaged or dirty and a careful gentle clean with a slighlty water dampened cloth may help. Whatever you do don't use any sprays on the membrane layers as that will kill it for good. They come apart easily but take photos as you go as they are harder to reassemble than disassemble.
 
1 - 4 of 4 Posts
Top