Ford Forums banner

1 - 5 of 5 Posts

·
EFII Ghia owner
Joined
·
355 Posts
Discussion Starter #1
hi all,
i own an EFII Ghia I6. today i gave her a bit of stick from the lights and the temp climed up to the 'O' where it says normal on the guage. it seemed pretty high, although it is a 36 degree day. the guage normally points to about the 'A' in normal driving. is this normal, or is there sometime wrong with my cooling system? i have just got the thermostat housing relpaced.
also, today the car was sometimes shaking quite hard on idol (at normal temp) with the revs climing to 900rpm then droping to 500rpm
any help would be great, thanks
 

·
R31 owner, Ford supporter
Joined
·
60 Posts
Hey, at least your temperature guage tells you what's going on, our '99 Magna says exactly halfway every day, hot, cold, doing 160km/h - I think it's lying to me! I just hope it doesn't get me into trouble this summer! GL with the prob..
 

·
Registered
Joined
·
847 Posts
Did it drop back down at all and if so did it do it quick or did it take a while. When the thermostat housing was changed, did they install a new thermostat, or is it the old one?
 

·
EFII Ghia owner
Joined
·
355 Posts
Discussion Starter #4
i was almost home anyway, but it did seem to very slowly start to cool down. when i got home the thermo fans turned off even though the temperature was still alot higher then normal.
as far as i know the thermostat was replaced, but it seems to be still leaking as there is, what seems to be dryed up coolant all over it
 

·
In a blue Galaxy
Joined
·
5,716 Posts
Drive the car again and if the problem still occurs check the temperature of the radiator by running your hand up and down. If it's too hot to touch on top but cooler as you run your hand lower down it then your radiator is blocked.
 
1 - 5 of 5 Posts
Top