Ford Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter #1
Heyall,

With my fairmont ghia, if I run with my full beams on for a while, after a certain amount of time, the lights will flicker all over the place, the dash likes would flicker like mad etc, to fix it, I have to turn off the main lights then turn them on again, not too good when you are out bush doing 100kmh. ;)

Any ideas as to what this would be ?

Also the hazard lights don't work, and if I have the hazard light button pressed it, the indicators won't work either. :(

Thanks heaps everyone. :D
 

·
Crazed Cone Chaser
Joined
·
2,524 Posts
Sounds like you're relays might be playing up.

I'd check them out first.
 

·
BA'o'Matic 100% working.
Joined
·
3,838 Posts
There is a medium dize metal thing unde the bonnet with either BIG yellow or BIG pink and white wires running in and out of it, its a breaker and is causing the problem, replace it, or i was naughty and soldered across the terminals solved the problem.

Jason
 

·
Registered
Joined
·
128 Posts
Discussion Starter #4
Ok thanks mate, I still don't really know what 'medium size metal thing' is...

I'll have another look at it this arvo, and I have replaced the relay's to no avail
 

·
BA'o'Matic 100% working.
Joined
·
3,838 Posts
I dont have a pic, but it will be located drivers side in the engine bay, near the overflow tank area usually, (Trace the relay wires for the lights) t will make sense when you find it , really it will :0)

Jason
 
1 - 6 of 6 Posts
Top