Ford Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
When I let off just alittle it will pick back up...I have heard that it could be a mass air flow sensor, I have heard it could be a computer problem or even a position sensor...I have a new fuel filter,plugs,wires,belt,o2 sensors and pcv valves...What else could it be...Ireally need help I love This car and I bought it new...Can anybody help me I dont know what else to do other than spend 110 dollars at the dealership putting it on a computer that might help it might not so any help would be appreciated
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Jrgicehc said:
could be the fuel pump, has it been getting progressively worse?
yep it started about a year ago but not as bad...is the fuel pump hard to change do you know...I appreciate the help and hope you have a great day...its a 97 crownvic by the way...
 

·
Registered
Joined
·
6 Posts
i dont know if it is hard to change or not, i have actually never had that happen to my crown vic. but my chrysler new yorker is having the same problem right now and i have had it happen to my oldsmobile. i have been avoiding the new yorker because it is in the fuel tank and i have to drop it to get to it. im new to the crown victoria so im not sure where it is. either way i would have a mechanic look at it because it may or may not be the fuel pump. but it definately sounds like you are loosing fuel pressure.
 
U

·
Guest
Joined
·
0 Posts
Jrgicehc said:
i dont know if it is hard to change or not, i have actually never had that happen to my crown vic. but my chrysler new yorker is having the same problem right now and i have had it happen to my oldsmobile. i have been avoiding the new yorker because it is in the fuel tank and i have to drop it to get to it. im new to the crown victoria so im not sure where it is. either way i would have a mechanic look at it because it may or may not be the fuel pump. but it definately sounds like you are loosing fuel pressure.
Thanks for the advice I guess ill spend alittle green to get it on a computer and see what it says...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Jrgicehc said:
i dont know if it is hard to change or not, i have actually never had that happen to my crown vic. but my chrysler new yorker is having the same problem right now and i have had it happen to my oldsmobile. i have been avoiding the new yorker because it is in the fuel tank and i have to drop it to get to it. im new to the crown victoria so im not sure where it is. either way i would have a mechanic look at it because it may or may not be the fuel pump. but it definately sounds like you are loosing fuel pressure.
Thanks for the help Ill just get it on a computer instead of just throwing parts at it...Im no mechanic so I better let em handle it...Thanks again
 

·
Registered
Joined
·
833 Posts
The fuel pump is located in the tank on those cars.
If you're not accustomed to diagnosing problems, I'd say let the professionals handle that one- it's likely going to be a fairly in-depth diagnosis. In the least, they can tell you what you broke ( :priest: ) and you can swap the parts yourself.
 
U

·
Guest
Joined
·
0 Posts
Freshmeat said:
The fuel pump is located in the tank on those cars.
If you're not accustomed to diagnosing problems, I'd say let the professionals handle that one- it's likely going to be a fairly in-depth diagnosis. In the least, they can tell you what you broke ( :priest: ) and you can swap the parts yourself.
Thanks for all of your help Ill put her under the knife ASAP.
 

·
Registered
Joined
·
10 Posts
my car does this under full throttle around corners with not alot of gas in the tank. i believe the gas sloshes to one side and the pump starves... never happens in a straight line only when burning ass around a corner or pulling out on the highway really fast with like 2 gallons of gas in the tank. same thing or is my situation different?
 

·
Registered
Joined
·
10 Posts
no way!! its way to fun... this cars engine started on fire when the previous owner had it and it was still under warranty way back in early 90s, so they replaced the engine with a 89-90 not exactly sure which one.. the body is a 86 all i can say is i think they put a 302 out of a f150 in it or something cuz there is no way in hell this thing is the stock motors hp rating.. its just way to strong compared to any other older body style crown, marquis or towncar ive ever drove. this thing is so unigue on how it feels to drive its weird. maybe its the smaller diameter tires and the hundreds of pounds of weight ive shed multiplied with all the parts and work ive done to it over the years. i have pounded the hell out of this car ever since ive had it, raced ricers and done 360 burnouts till the tires disinegrated and it to this day has never failed me, it starts up on the first crank in below zero weather and you all know how the heaters kick ass.. i honestly have to say this has to be one of the most reliable fool proof cars ever made except for just wear and tear shit that every car goes through and maybe the crappy ass paint ford produced in the 80s. rock on ford 5.0..................
 
1 - 11 of 11 Posts
Top