Ford Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
I recently had the frontbumper/air dam replaced on my 1995 EF falcon, and headlights thanks to a not-particularly-observant tourist.

When my car returned from the sprayshop I did an oil change and to get at the filter from the top of the engine bay I removed the airfilter box.

In front of the air filter box, attached to a holder is a bank of 4 fuses/relays/links. Not sure what they are as they are only numbered 1 to 4 and my workshop manual makes no reference to them, or that they are even there.

Problem is, the first time I used my car after it returned from the sprayshop, at night when the lights are on, none of the dash illumination works anymore. The clock, odometer and warning lights all work, just not the illumination for me to see how fast I am going or if I have gas.

The next day when I start to look at the problem I also discover my hazard lights don't go. The indicators all work perfectly as they should, just not when I push the hazard light switch.

Also, no rear tail lamps when my headlights are on, and no warning buzzer/bell when I turn the car off and leave the headlights on.

To avoid the obvious comments, yes I have checked every fuse under the dash on the drivers side. They are all good.
I thought there might be a fuse blown, that is common to the tail lamps, headlight warning buzzer and dash lights, but I wouldn't have thought they would also be tied to the hazard lights. I was also hoping it was one of the ones in front of the airbox, but the workshop manual doesn't even show that they exist.

Has anyone had any or all of these faults before, if so, please help.
Or even if you know what the little bastards in front of the airbox are.

Thanks for any info that anyone can provide.
Craig
 

·
Got my 3.45 LSD!
Joined
·
214 Posts
just out of curiousity was ur headlight loom replaced or were the original ones used?
take it back 2 your panelbeater/sprayshop and get them 2 fix it and claim it as their fault, they may have cut something.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #3
Still original loom. Just new lights that plug straight in.
I'm about to take it back because I can't work out what has popped.
It's pissing me off. It should be so simple.
 

·
Registered
Joined
·
141 Posts
You state twice that your workshop manual makes no mention of the relays controlling the thermo fans. You clearly do not have a workshop manual, what you have is a crap aftermarket copy, Gregorys, haynes etc... Lob it in the bin and buy a proper Ford workshop manual. All will be revealed.
 

·
Super Moderator
Joined
·
3,754 Posts
While I agree that the Haynes manual isn't as good as the genuine Ford one, you get what you pay for and the fan relays are mentioned (page 3-3 and 12-3) in my copy.
 
1 - 6 of 6 Posts
Top