Ford Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
I'm the proud owner of a 4 month old XR8 ute. I was wondering if anyone else has experienced a slight noise eminating from the engine bay around the 2750 rpm mark? I heard it for the first time right before I went in for my 3000k service. Got the dealer to go for a spin, he heard it too and made not of it for the service guys. Post mortem from the service guys said they tightened the heat shield and sure enough the noise disappeared for the time being.....but alas the Ford Empire Strikes Back yet again. Am up to about 5500 k's and its shitting me again. I doubt its doing any damage, but as fate would have it, the day I go to sell it I'm sure the first thing any potential buyer will ask is "errr, what's that noise I hear around 2500 rpm??".

Anyway, just keen to hear if its a common prob or if I'm the only victim out there. I'm sure the warranty will cover it, but if its a matter of just re-tightening the shield then I can't honestly be f.cked heading back to my dealer to get it done, nor should I be expected to.

Cheers,
Simmo.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
Just as a footnote, got the guys at teh dealership to look into it. Exhaust heat shield, not an 'engine' shield as such. They tightened it up again and hey presto!, its gone for now.....


and while im on the maintenance shite, look out for clicking in your steering. Common problem and there is a fix out there for it. Talk to your dealers (or is this old news and everyone already knows about it but me?)


Cheers,
Simmo.
 
1 - 3 of 3 Posts
Top